Whamcloud - gitweb
Lproc-snmp code drop
[fs/lustre-release.git] / lustre / mdc / Makefile.am
index 4069f6b..26c0053 100644 (file)
@@ -3,20 +3,23 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-DEFS:=
+DEFS=
 
 MODULE = mdc
 modulefs_DATA = mdc.o
 EXTRA_PROGRAMS = mdc
 
 
 MODULE = mdc
 modulefs_DATA = mdc.o
 EXTRA_PROGRAMS = mdc
 
-LINX=mds_updates.c
-mdc_SOURCES =  mdc_request.c mdc_reint.c $(LINX)
+LINX= mds_updates.c ll_pack.c lov_pack.c client.c
+mdc_SOURCES =  mdc_request.c mdc_reint.c lproc_mdc.c $(LINX)
 
 
+lov_pack.c: 
+       test -e lov_pack.c || ln -sf $(top_srcdir)/lib/lov_pack.c .
+ll_pack.c: 
+       test -e ll_pack.c || ln -sf $(top_srcdir)/lib/ll_pack.c .
 mds_updates.c: 
        test -e mds_updates.c || ln -sf $(top_srcdir)/lib/mds_updates.c .
 mds_updates.c: 
        test -e mds_updates.c || ln -sf $(top_srcdir)/lib/mds_updates.c .
-
-dist-hook:
-       list='$(LINX)'; for f in $$list; do rm -f $(distdir)/$$f; done
+client.c: 
+       test -e client.c || ln -sf $(top_srcdir)/lib/client.c .
 
 
 include $(top_srcdir)/Rules
 
 
 include $(top_srcdir)/Rules