Whamcloud - gitweb
A mostly-fix for "mknod /mnt/lustre/foofo p". It doesn't fail outright
[fs/lustre-release.git] / lustre / mdc / Makefile.am
index b412741..1b5d201 100644 (file)
@@ -3,14 +3,17 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-DEFS:=
+DEFS=
 
 MODULE = mdc
 modulefs_DATA = mdc.o
 EXTRA_PROGRAMS = mdc
 
-LINX=mds_updates.c ll_pack.c
+LINX=mds_updates.c ll_pack.c lov_pack.c
 mdc_SOURCES =  mdc_request.c mdc_reint.c $(LINX)
+lov_pack.c: 
+       test -e lov_pack.c || ln -sf $(top_srcdir)/lib/lov_pack.c .
+
 ll_pack.c: 
        test -e ll_pack.c || ln -sf $(top_srcdir)/lib/ll_pack.c .