Whamcloud - gitweb
smash the HEAD with the contents of b_cmd. HEAD_PRE_CMD_SMASH and
[fs/lustre-release.git] / lustre / mdc / Makefile.am
similarity index 57%
rename from lustre/mdc/autoMakefile.am
rename to lustre/mdc/Makefile.am
index e46e120..0200532 100644 (file)
@@ -3,16 +3,18 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
+DEFS=
+
 if LIBLUSTRE
 noinst_LIBRARIES = libmdc.a
 libmdc_a_SOURCES = mdc_request.c mdc_reint.c mdc_lib.c mdc_internal.h mdc_locks.c
-libmdc_a_CPPFLAGS = $(LLCPPFLAGS)
-libmdc_a_CFLAGS = $(LLCFLAGS)
-endif
+libmdc_a_CFLAGS = -fPIC
+else
+MODULE = mdc
+modulefs_DATA = mdc.o
+EXTRA_PROGRAMS = mdc
 
-if MODULES
-modulefs_DATA = mdc$(KMODEXT)
+mdc_SOURCES = mdc_request.c mdc_reint.c lproc_mdc.c mdc_lib.c mdc_locks.c mdc_internal.h
 endif
 
-DIST_SOURCES = $(mdc-objs:.o=.c) mdc_internal.h
-MOSTLYCLEANFILES = *.o *.ko *.mod.c
+include $(top_srcdir)/Rules