Whamcloud - gitweb
Another slightly less rough cut at XML based configuration. There
[fs/lustre-release.git] / lustre / llite / Makefile.am
index cd4d49d..88aa73c 100644 (file)
@@ -3,11 +3,20 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-MODULE = llight
-modulefs_DATA = llight.o
-EXTRA_PROGRAMS = llight
+DEFS:= 
 
+MODULE = llite
+modulefs_DATA = llite.o
+EXTRA_PROGRAMS = llite
 
-llight_SOURCES =  super.c rw.c file.c dir.c sysctl.c namei.c symlink.c
+page.c: 
+       test -e page.c || ln -sf $(top_srcdir)/lib/page.c
+
+
+LINX=page.c
+llite_SOURCES =  dcache.c recover.c commit_callback.c page.c super.c rw.c file.c dir.c sysctl.c namei.c symlink.c
+
+dist-hook:
+       list='$(LINX)'; for f in $$list; do rm -f $(distdir)/$$f; done
 
 include $(top_srcdir)/Rules