Whamcloud - gitweb
LU-3382 build: clean unused link dependencies
[fs/lustre-release.git] / lustre / liblustre / tests / Makefile.am
index ee16557..c6c7e27 100644 (file)
@@ -1,31 +1,33 @@
 ## Liblustre excecutables & libraries Makefile
 
 ## Liblustre excecutables & libraries Makefile
 
-AM_CPPFLAGS = -I$(SYSIO)/include -I/opt/lam/include $(LLCPPFLAGS) -I$(top_srcdir)/portals/unals
+AM_CPPFLAGS = -I$(SYSIO)/include -I/opt/lam/include $(LLCPPFLAGS) -I$(top_srcdir)/lnet/ulnds
 AM_CFLAGS = $(LLCFLAGS)
 AM_CFLAGS = $(LLCFLAGS)
-LIBS = $(LIBEFENCE) $(LIBREADLINE)
+AM_LIBS = $(LIBEFENCE) $(LIBREADLINE)
 
 
-LLIB_EXEC= $(top_builddir)/lustre/liblustre/liblustre.a -lcap -lpthread
+LLIB_EXEC = $(top_builddir)/lustre/utils/liblustreapi.a $(top_builddir)/lustre/liblustre/liblustre.a $(CAP_LIBS) $(PTHREAD_LIBS)
 
 if LIBLUSTRE
 noinst_LIBRARIES = libtestcommon.a
 
 if LIBLUSTRE
 noinst_LIBRARIES = libtestcommon.a
-def_tests = echo_test sanity recovery_small replay_single replay_ost_single
 
 
+if LIBLUSTRE_TESTS
 if MPITESTS
 if MPITESTS
-noinst_PROGRAMS = $(def_tests) test_lock_cancel
-else
-noinst_PROGRAMS = $(def_tests)
-endif
-endif # LIBLUSTRE
+SUBDIRS = mpi
+endif # MPITESTS
 
 
-libtestcommon_a_SOURCES = test_common.c test_common.h
+noinst_PROGRAMS = sanity
+
+noinst_PROGRAMS += recovery_small replay_single replay_ost_single
 
 
-echo_test_SOURCES = echo_test.c $(top_srcdir)/lustre/utils/parser.c    \
-       $(top_srcdir)/lustre/utils/obd.c                                \
-       $(top_srcdir)/lustre/utils/lustre_cfg.c
+liblustre_testdir=$(libdir)/lustre/liblustre/tests
+liblustre_test_PROGRAMS = $(noinst_PROGRAMS)
+liblustre_test_LIBRARIES = $(noinst_LIBRARIES)
 
 
-echo_test_CFLAGS = $(LL_CFLAGS)
-echo_test_LDADD = $(top_builddir)/lustre/liblustre/liblsupport.a $(LIBREADLINE) -lcap -lpthread 
-echo_test_DEPENDENCIES=$(top_builddir)/lustre/liblustre/liblsupport.a
+endif # LIBLUSTRE_TESTS
+endif # LIBLUSTRE
+
+DIST_SUBDIRS = mpi
+
+libtestcommon_a_SOURCES = test_common.c test_common.h
 
 sanity_SOURCES = sanity.c
 sanity_CFLAGS = $(LL_CFLAGS)
 
 sanity_SOURCES = sanity.c
 sanity_CFLAGS = $(LL_CFLAGS)
@@ -46,11 +48,3 @@ replay_ost_single_SOURCES = replay_ost_single.c
 replay_ost_single_CFLAGS = $(LL_CFLAGS)
 replay_ost_single_LDADD := libtestcommon.a $(LLIB_EXEC)
 replay_ost_single_DEPENDENCIES = $(top_builddir)/lustre/liblustre/liblustre.a libtestcommon.a
 replay_ost_single_CFLAGS = $(LL_CFLAGS)
 replay_ost_single_LDADD := libtestcommon.a $(LLIB_EXEC)
 replay_ost_single_DEPENDENCIES = $(top_builddir)/lustre/liblustre/liblustre.a libtestcommon.a
-
-if MPITESTS
-test_lock_cancel_SOURCES = test_lock_cancel.c
-test_lock_cancel_CFLAGS = $(LL_CFLAGS) -I/opt/lam/include
-test_lock_cancel_LDADD :=  $(LLIB_EXEC)  -L/opt/lam/lib -lmpi -llam
-endif
-
-