Whamcloud - gitweb
LU-3382 build: clean unused link dependencies
[fs/lustre-release.git] / lustre / liblustre / tests / Makefile.am
index 77d62b2..c6c7e27 100644 (file)
@@ -1,52 +1,50 @@
 ## Liblustre excecutables & libraries Makefile
 ## Liblustre excecutables & libraries Makefile
-DEFS=
 
 
-AM_CFLAGS := -g -Wall -I$(top_srcdir)/utils -I$(top_srcdir)/portals/include \
-          -I$(top_srcdir)/portals/unals -I$(SYSIO)/include \
-          -I/opt/lam/include -L/opt/lam/lib
+AM_CPPFLAGS = -I$(SYSIO)/include -I/opt/lam/include $(LLCPPFLAGS) -I$(top_srcdir)/lnet/ulnds
+AM_CFLAGS = $(LLCFLAGS)
+AM_LIBS = $(LIBEFENCE) $(LIBREADLINE)
 
 
-KFLAGS:=
-CPPFLAGS = $(HAVE_EFENCE) -D_LARGEFILE64_SOURCE=1
-LIBS = $(LIBEFENCE)
+LLIB_EXEC = $(top_builddir)/lustre/utils/liblustreapi.a $(top_builddir)/lustre/liblustre/liblustre.a $(CAP_LIBS) $(PTHREAD_LIBS)
 
 
+if LIBLUSTRE
+noinst_LIBRARIES = libtestcommon.a
 
 
-LLIB_EXEC= ../liblustre.a -lpthread
+if LIBLUSTRE_TESTS
+if MPITESTS
+SUBDIRS = mpi
+endif # MPITESTS
 
 
-noinst_LIBRARIES = libtestcommon.a
-libtestcommon_a_SOURCES = test_common.c
+noinst_PROGRAMS = sanity
 
 
-def_tests = echo_test sanity recovery_small replay_single replay_ost_single
+noinst_PROGRAMS += recovery_small replay_single replay_ost_single
 
 
-if MPITESTS
-bin_PROGRAMS = $(def_tests) test_lock_cancel
-else
-bin_PROGRAMS = $(def_tests)
-endif
+liblustre_testdir=$(libdir)/lustre/liblustre/tests
+liblustre_test_PROGRAMS = $(noinst_PROGRAMS)
+liblustre_test_LIBRARIES = $(noinst_LIBRARIES)
+
+endif # LIBLUSTRE_TESTS
+endif # LIBLUSTRE
 
 
-echo_test_SOURCES = echo_test.c  ../../utils/parser.c ../../utils/obd.c ../../utils/lustre_cfg.c
-echo_test_LDADD = ../liblsupport.a $(LIBREADLINE) -lpthread 
-echo_test_DEPENDENCIES=$(top_srcdir)/liblustre/liblsupport.a
+DIST_SUBDIRS = mpi
+
+libtestcommon_a_SOURCES = test_common.c test_common.h
 
 sanity_SOURCES = sanity.c
 
 sanity_SOURCES = sanity.c
-sanity_LDADD := ./libtestcommon.a $(LLIB_EXEC)
-sanity_DEPENDENCIES = $(top_srcdir)/liblustre/liblustre.a ./libtestcommon.a
+sanity_CFLAGS = $(LL_CFLAGS)
+sanity_LDADD := libtestcommon.a $(LLIB_EXEC)
+sanity_DEPENDENCIES = $(top_builddir)/lustre/liblustre/liblustre.a libtestcommon.a
 
 recovery_small_SOURCES = recovery_small.c
 
 recovery_small_SOURCES = recovery_small.c
-recovery_small_LDADD := ./libtestcommon.a $(LLIB_EXEC) 
-recovery_small_DEPENDENCIES = $(top_srcdir)/liblustre/liblustre.a
+recovery_small_CFLAGS = $(LL_CFLAGS)
+recovery_small_LDADD := libtestcommon.a $(LLIB_EXEC) 
+recovery_small_DEPENDENCIES = $(top_builddir)/lustre/liblustre/liblustre.a libtestcommon.a
 
 replay_single_SOURCES = replay_single.c
 
 replay_single_SOURCES = replay_single.c
-replay_single_LDADD := ./libtestcommon.a $(LLIB_EXEC)
-replay_single_DEPENDENCIES = $(top_srcdir)/liblustre/liblustre.a
+replay_single_CFLAGS = $(LL_CFLAGS)
+replay_single_LDADD := libtestcommon.a $(LLIB_EXEC)
+replay_single_DEPENDENCIES = $(top_builddir)/lustre/liblustre/liblustre.a libtestcommon.a
 
 replay_ost_single_SOURCES = replay_ost_single.c
 
 replay_ost_single_SOURCES = replay_ost_single.c
-replay_ost_single_LDADD := ./libtestcommon.a $(LLIB_EXEC)
-replay_ost_single_DEPENDENCIES = $(top_srcdir)/liblustre/liblustre.a
-
-if MPITESTS
-test_lock_cancel_SOURCES = test_lock_cancel.c
-test_lock_cancel_LDADD :=  $(LLIB_EXEC) -lmpi -llam
-endif
-
-include $(top_srcdir)/Rules
-
+replay_ost_single_CFLAGS = $(LL_CFLAGS)
+replay_ost_single_LDADD := libtestcommon.a $(LLIB_EXEC)
+replay_ost_single_DEPENDENCIES = $(top_builddir)/lustre/liblustre/liblustre.a libtestcommon.a