Whamcloud - gitweb
LU-3382 build: clean unused link dependencies
[fs/lustre-release.git] / lustre / liblustre / tests / Makefile.am
index 75943ff..c6c7e27 100644 (file)
@@ -10,25 +10,24 @@ if LIBLUSTRE
 noinst_LIBRARIES = libtestcommon.a
 
 if LIBLUSTRE_TESTS
 noinst_LIBRARIES = libtestcommon.a
 
 if LIBLUSTRE_TESTS
-noinst_PROGRAMS = sanity echo_test
+if MPITESTS
+SUBDIRS = mpi
+endif # MPITESTS
+
+noinst_PROGRAMS = sanity
 
 
-if !CRAY_XT3
 noinst_PROGRAMS += recovery_small replay_single replay_ost_single
 noinst_PROGRAMS += recovery_small replay_single replay_ost_single
-endif # !CRAY_XT3
 
 
-if MPITESTS
-noinst_PROGRAMS += test_lock_cancel
-endif # MPITESTS
+liblustre_testdir=$(libdir)/lustre/liblustre/tests
+liblustre_test_PROGRAMS = $(noinst_PROGRAMS)
+liblustre_test_LIBRARIES = $(noinst_LIBRARIES)
 
 endif # LIBLUSTRE_TESTS
 endif # LIBLUSTRE
 
 
 endif # LIBLUSTRE_TESTS
 endif # LIBLUSTRE
 
-libtestcommon_a_SOURCES = test_common.c test_common.h
+DIST_SUBDIRS = mpi
 
 
-echo_test_SOURCES = echo_test.c  $(top_srcdir)/lustre/utils/parser.c $(top_srcdir)/lustre/utils/obd.c $(top_srcdir)/lustre/utils/lustre_cfg.c
-echo_test_CFLAGS = $(LL_CFLAGS)
-echo_test_LDADD = $(top_builddir)/lustre/liblustre/liblsupport.a $(LIBREADLINE) $(CAP_LIBS) $(PTHREAD_LIBS) 
-echo_test_DEPENDENCIES=$(top_builddir)/lustre/liblustre/liblsupport.a
+libtestcommon_a_SOURCES = test_common.c test_common.h
 
 sanity_SOURCES = sanity.c
 sanity_CFLAGS = $(LL_CFLAGS)
 
 sanity_SOURCES = sanity.c
 sanity_CFLAGS = $(LL_CFLAGS)
@@ -49,11 +48,3 @@ replay_ost_single_SOURCES = replay_ost_single.c
 replay_ost_single_CFLAGS = $(LL_CFLAGS)
 replay_ost_single_LDADD := libtestcommon.a $(LLIB_EXEC)
 replay_ost_single_DEPENDENCIES = $(top_builddir)/lustre/liblustre/liblustre.a libtestcommon.a
 replay_ost_single_CFLAGS = $(LL_CFLAGS)
 replay_ost_single_LDADD := libtestcommon.a $(LLIB_EXEC)
 replay_ost_single_DEPENDENCIES = $(top_builddir)/lustre/liblustre/liblustre.a libtestcommon.a
-
-if MPITESTS
-test_lock_cancel_SOURCES = test_lock_cancel.c
-test_lock_cancel_CFLAGS = $(LL_CFLAGS) -I/opt/lam/include
-test_lock_cancel_LDADD :=  $(LLIB_EXEC)  -L/opt/lam/lib -lmpi -llam
-endif
-
-