Whamcloud - gitweb
b=20355 formalize support for pthreads
[fs/lustre-release.git] / lustre / liblustre / tests / Makefile.am
index 07726dd..39b22d0 100644 (file)
@@ -6,6 +6,9 @@ AM_LIBS = $(LIBEFENCE) $(LIBREADLINE)
 
 LLIB_EXEC = $(top_builddir)/lustre/utils/liblustreapi.a $(top_builddir)/lustre/liblustre/liblustre.a $(CAP_LIBS) $(PTHREAD_LIBS) $(ZLIB)
 
+CC = $(PTHREAD_CC)
+LD = $(PTHREAD_CC)
+
 if LIBLUSTRE
 noinst_LIBRARIES = libtestcommon.a
 
@@ -32,21 +35,25 @@ DIST_SUBDIRS := mpi
 libtestcommon_a_SOURCES = test_common.c test_common.h
 
 sanity_SOURCES = sanity.c
-sanity_CFLAGS = $(LL_CFLAGS)
+sanity_CFLAGS = $(LL_CFLAGS) $(PTHREAD_CFLAGS)
+sanity_LDFLAGS := $(PTHREAD_CFLAGS)
 sanity_LDADD := libtestcommon.a $(LLIB_EXEC)
 sanity_DEPENDENCIES = $(top_builddir)/lustre/liblustre/liblustre.a libtestcommon.a
 
 recovery_small_SOURCES = recovery_small.c
-recovery_small_CFLAGS = $(LL_CFLAGS)
+recovery_small_CFLAGS = $(LL_CFLAGS) $(PTHREAD_CFLAGS)
+recovery_small_LDFLAGS := $(PTHREAD_CFLAGS)
 recovery_small_LDADD := libtestcommon.a $(LLIB_EXEC) 
 recovery_small_DEPENDENCIES = $(top_builddir)/lustre/liblustre/liblustre.a libtestcommon.a
 
 replay_single_SOURCES = replay_single.c
-replay_single_CFLAGS = $(LL_CFLAGS)
+replay_single_CFLAGS = $(LL_CFLAGS) $(PTHREAD_CFLAGS)
+replay_single_LDFLAGS := $(PTHREAD_CFLAGS)
 replay_single_LDADD := libtestcommon.a $(LLIB_EXEC)
 replay_single_DEPENDENCIES = $(top_builddir)/lustre/liblustre/liblustre.a libtestcommon.a
 
 replay_ost_single_SOURCES = replay_ost_single.c
-replay_ost_single_CFLAGS = $(LL_CFLAGS)
+replay_ost_single_CFLAGS = $(LL_CFLAGS) $(PTHREAD_CFLAGS)
+replay_ost_single_LDFLAGS := $(PTHREAD_CFLAGS)
 replay_ost_single_LDADD := libtestcommon.a $(LLIB_EXEC)
 replay_ost_single_DEPENDENCIES = $(top_builddir)/lustre/liblustre/liblustre.a libtestcommon.a