Whamcloud - gitweb
LU-3321 clio: revert LU-2622 for removing global env list
[fs/lustre-release.git] / lustre / liblustre / Makefile.am
index 34fe48d..e0d75b1 100644 (file)
@@ -19,8 +19,7 @@ LUSTRE_LIBS = libllite.a \
               $(top_builddir)/lustre/mdc/libmdc.a \
               $(top_builddir)/lustre/mgc/libmgc.a \
               $(top_builddir)/lustre/ptlrpc/libptlrpc.a \
-              $(top_builddir)/lustre/obdclass/liblustreclass.a \
-              $(top_builddir)/lustre/lvfs/liblvfs.a
+             $(top_builddir)/lustre/obdclass/liblustreclass.a
 
 LND_LIBS =
 if BUILD_USOCKLND
@@ -28,8 +27,7 @@ LND_LIBS +=    $(top_builddir)/lnet/ulnds/socklnd/libsocklnd.a
 endif
 
 LNET_LIBS =   $(top_builddir)/lnet/utils/libuptlctl.a \
-              $(top_builddir)/lnet/lnet/liblnet.a \
-              $(top_builddir)/libcfs/libcfs/libcfsutil.a
+              $(top_builddir)/lnet/lnet/liblnet.a
 
 SYSIO_LIBS =  $(SYSIO)/lib/libsysio.a
 
@@ -59,6 +57,11 @@ libllite_a_SOURCES = llite_lib.c super.c namei.c rw.c file.c dir.c \
 liblustre_a_SOURCES = llite_lib.c super.c namei.c rw.c file.c dir.c \
                     llite_lib.h llite_cl.c
 
+export CC
+export LDFLAGS
+export AR
+export RANLIB
+
 liblustre.a : $(LUSTRE_LIBS) $(LND_LIBS) $(LNET_LIBS) $(SYSIO_LIBS)
        sh $(srcdir)/genlib.sh "$(SYSIO)" "$(LIBS)" "$(LND_LIBS)" "$(PTHREAD_LIBS)" "$(CAP_LIBS)" "$(ZLIB)"