Whamcloud - gitweb
Fixes from b_port_step needed to get HEAD to build.
[fs/lustre-release.git] / lustre / liblustre / Makefile.am
index 665295e..90a35c4 100644 (file)
@@ -1,18 +1,61 @@
-# Administration utilities Makefile
-DEFS=
+## Liblustre excecutables & libraries Makefile
+SUBDIRS = . tests
 
-CFLAGS:=-g -O2 -I$(top_srcdir)/utils -I$(PORTALS)/include  -I$(srcdir)/../include -Wall -L$(PORTALSLIB)
+AM_CPPFLAGS = $(HAVE_EFENCE) -I$(SYSIO)/include -D_LARGEFILE64_SOURCE=1 \
+              $(LLCPPFLAGS) -I$(top_srcdir)/portals/unals
+AM_CFLAGS = $(LLCFLAGS)
 
-KFLAGS:=
-CPPFLAGS = $(HAVE_EFENCE)
 LIBS = $(LIBEFENCE)
-LLIBS= ../lov/liblov.a ../obdecho/libobdecho.a ../osc/libosc.a ../ldlm/libldlm.a  ../ptlrpc/libptlrpc.a ../obdclass/liblustreclass.a
 
-libtest_LDADD := $(LIBREADLINE)  $(LLIBS) \
-                 $(PORTALS)/user/procbridge/libprocbridge.a  $(PORTALS)/user/tcpnal/libtcpnal.a \
-                $(PORTALS)/user/util/libtcpnalutil.a $(PORTALS)/api/libptlapi.a \
-                 $(PORTALS)/lib/libptllib.a -lptlctl -lpthread 
-bin_PROGRAMS = libtest
-libtest_SOURCES = libtest.c
+LUSTRE_LIBS = liblutils.a libllite.a \
+              $(top_builddir)/lustre/lov/liblov.a \
+              $(top_builddir)/lustre/obdecho/libobdecho.a \
+              $(top_builddir)/lustre/osc/libosc.a \
+              $(top_builddir)/lustre/mdc/libmdc.a \
+              $(top_builddir)/lustre/ptlrpc/libptlrpc.a \
+              $(top_builddir)/lustre/obdclass/liblustreclass.a \
+              $(top_builddir)/lustre/lvfs/liblvfs.a
 
-include $(top_srcdir)/Rules
+if !CRAY_PORTALS
+PTL_LIBS =    $(top_builddir)/portals/utils/libuptlctl.a \
+              $(top_builddir)/portals/unals/libtcpnal.a \
+              $(top_builddir)/portals/portals/libportals.a
+else
+PTL_LIBS =    $(top_builddir)/portals/utils/libuptlctl.a \
+              $(CRAY_PORTALS_PATH)/lib_TV/snos64/libportals.a
+endif
+
+SYSIO_LIBS =  $(SYSIO)/lib/libsysio.a
+
+if LIBLUSTRE
+lib_LIBRARIES = liblustre.a
+noinst_LIBRARIES = liblutils.a libllite.a
+
+install-exec-hook: liblustre.so
+       @$(NORMAL_INSTALL)
+       $(mkinstalldirs) $(DESTDIR)$(libdir)
+       @list=$< ; for p in $$list; do \
+         if test -f $$p; then \
+           f="`echo $$p | sed -e 's|^.*/||'`"; \
+           echo " $(libLIBRARIES_INSTALL) $$p $(DESTDIR)$(libdir)/$$f"; \
+           $(libLIBRARIES_INSTALL) $$p $(DESTDIR)$(libdir)/$$f; \
+         else :; fi; \
+       done
+else
+install-exec-hook:
+endif
+
+liblutils_a_SOURCES = lutil.c lutil.h
+
+libllite_a_SOURCES = llite_lib.c super.c namei.c rw.c file.c dir.c \
+                    llite_lib.h
+
+# for make rpms -- need cleanup
+liblustre_a_SOURCES = llite_lib.c super.c namei.c rw.c file.c dir.c
+
+liblustre.a : $(LUSTRE_LIBS) $(PTL_LIBS) $(SYSIO_LIBS)
+       sh $(srcdir)/genlib.sh $(SYSIO) $(CRAY_PORTALS_PATH)
+
+EXTRA_DIST = genlib.sh
+
+CLEANFILES := liblsupport.a liblustre.so