Whamcloud - gitweb
b=3031
[fs/lustre-release.git] / lustre / ldlm / Makefile.am
index c060a2b..4f05281 100644 (file)
@@ -3,15 +3,11 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-DEFS:= 
-MODULE = ldlm
-modulefs_DATA = ldlm.o
-EXTRA_PROGRAMS = ldlm
-
-pack_generic.c:
-       ln -s ../lib/pack_generic.c
-ldlm_SOURCES = ldlm_lock.c ldlm_resource.c ldlm_test.c ldlm_lockd.c \
-ldlm_extent.c pack_generic.c
-
-include $(top_srcdir)/Rules
+#
+# ldlm is built into ptlrpc
+#
 
+MOSTLYCLEANFILES := @MOSTLYCLEANFILES@ 
+DIST_SOURCES = ldlm_extent.c ldlm_flock.c ldlm_internal.h ldlm_lib.c \
+       ldlm_lock.c ldlm_lockd.c ldlm_plain.c ldlm_request.c         \
+       ldlm_resource.c ldlm_test.c l_lock.c ldlm_inodebits.c