Whamcloud - gitweb
Don't copy lvb into reply message on error, since that message might not have
[fs/lustre-release.git] / lustre / ldlm / Makefile.am
index a76ff4a..0da12fc 100644 (file)
@@ -3,13 +3,17 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
+#
+# ldlm is built into ptlrpc
+#
+
 DEFS= 
-MODULE = ldlm
-modulefs_DATA = ldlm.o
-EXTRA_PROGRAMS = ldlm
 
-ldlm_SOURCES = l_lock.c ldlm_lock.c ldlm_resource.c ldlm_lockd.c \
-ldlm_extent.c ldlm_request.c
+if LIBLUSTRE
+lib_LIBRARIES = libldlm.a
+libldlm_a_SOURCES = l_lock.c ldlm_lock.c ldlm_resource.c ldlm_lib.c \
+  ldlm_plain.c ldlm_extent.c ldlm_request.c ldlm_lockd.c ldlm_internal.h
+libldlm_a_CFLAGS = -fPIC
+endif
 
 include $(top_srcdir)/Rules
-