Whamcloud - gitweb
Branch HEAD
[fs/lustre-release.git] / lustre / kernel_patches / which_patch
index 2ef001d..68c7d2c 100644 (file)
@@ -1,13 +1,18 @@
-SERIES               MEMNONIC                  COMMENT
+SERIES                VERSION                  COMMENT
 
-hp-pnnl-2.4.20       linux-2.4.20-hp4_pnnl1    same as vanilla but no uml
-vanilla-2.4.20       linux-2.4.20              patch includes uml
-chaos-2.4.20         linux-chaos-2.4.20        same as rh-2.4.20-8
-rh-2.4.20            linux-rh-2.4.20-8         same as chaos-2.4.20
-rh-2.4.18-18         linux-rh-2.4.18-18        same as chaos but includes uml
-chaos                linux-chaos-2.4.18        same as rh-2.4.18-18 but no uml
+SUPPORTED KERNELS:
+2.6-suse              SLES9 before SP1         already in SLES9 SP1 kernel
+2.6-suse-newer        SLES9: 2.6.5-7.286       extra patches for SLES9 after SP1
+2.6-rhel4             RHEL4: 2.6.9-55.0.9.EL
+2.6-sles10            SLES10: 2.6.16.53-0.8
+2.6-rhel5.series      RHEL5: 2.6.18-8.1.14.el5
+2.6.18-vanilla.series kernel.org: 2.6.18.8
 
-REVIEW:
+CLIENT SUPPORT FOR UNPATCHED KERNELS:
+                   kernel.org 2.6.16-2.6.19
+                   RHEL4: 2.6.9-42.0.8EL
 
-vanilla-2.5          linux-2.5.63
-hp-pnnl              linux-2.4.19-hp2_pnnl6
+NB - The patches in the 2.6-suse series should already be in the SLES9 SP1
+     kernel.  The patches in the 2.6-suse-newer series are patches that
+     have been created since the SP1 kernel was released and should be
+     applied to the already-patched SP1 kernel.