Whamcloud - gitweb
Branch HEAD
[fs/lustre-release.git] / lustre / kernel_patches / which_patch
index 09c69f0..68c7d2c 100644 (file)
@@ -1,22 +1,18 @@
-SERIES             VERSION                  COMMENT
+SERIES                VERSION                  COMMENT
 
 SUPPORTED KERNELS:
-rhel-2.4.21        RHEL3: 2.4.21-47.0.1.EL
-2.6-suse           SLES9 before SP1         already in SLES9 SP1 kernel
-2.6-suse-newer     SLES9: 2.6.5-7.282       extra patches for SLES9 after SP1
-2.6-rhel4          RHEL4: 2.6.9-42.0.8.EL
-2.6.12-vanilla     kernel.org: 2.6.12.6
-2.6-sles10         SLES10: 2.6.16.21-0.8
+2.6-suse              SLES9 before SP1         already in SLES9 SP1 kernel
+2.6-suse-newer        SLES9: 2.6.5-7.286       extra patches for SLES9 after SP1
+2.6-rhel4             RHEL4: 2.6.9-55.0.9.EL
+2.6-sles10            SLES10: 2.6.16.53-0.8
+2.6-rhel5.series      RHEL5: 2.6.18-8.1.14.el5
+2.6.18-vanilla.series kernel.org: 2.6.18.8
+
+CLIENT SUPPORT FOR UNPATCHED KERNELS:
+                   kernel.org 2.6.16-2.6.19
+                   RHEL4: 2.6.9-42.0.8EL
 
 NB - The patches in the 2.6-suse series should already be in the SLES9 SP1
      kernel.  The patches in the 2.6-suse-newer series are patches that
      have been created since the SP1 kernel was released and should be
      applied to the already-patched SP1 kernel.
-
-NB - The patches in the ldiskfs series should not be applied to the kernel.
-     They are instead applied by the lustre build process to create the
-     ldiskfs kernel module instead of modifying the core ext3 code.
-
-UNSUPPORTED KERNELS; BEING PHASED OUT; MAY BE MISSING CRITICAL BUG FIXES:
-hp-pnnl-2.4.20     linux-2.4.20-hp4_pnnl1   same as vanilla but no uml  ia64
-vanilla-2.4.24     linux-2.4.24             patch with uml-2.4.24-6     um