Whamcloud - gitweb
LU-709 build: clean up quota_read, follow_link and RCU
[fs/lustre-release.git] / lustre / include / linux / Makefile.am
index cbd47a9..2dd1aae 100644 (file)
@@ -1,17 +1,47 @@
-# Copyright (C) 2001  Cluster File Systems, Inc.
 #
-# This code is issued under the GNU General Public License.
-# See the file COPYING in this distribution
+# GPL HEADER START
+#
+# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2 only,
+# as published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# General Public License version 2 for more details (a copy is included
+# in the LICENSE file that accompanied this code).
+#
+# You should have received a copy of the GNU General Public License
+# version 2 along with this program; If not, see
+# http://www.sun.com/software/products/lustre/docs/GPLv2.pdf
+#
+# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
+# CA 95054 USA or visit www.sun.com if you need additional information or
+# have any questions.
+#
+# GPL HEADER END
+#
+
+#
+# Copyright (c) 2003, 2010, Oracle and/or its affiliates. All rights reserved.
+# Use is subject to license terms.
+#
+
+#
+# This file is part of Lustre, http://www.lustre.org/
+# Lustre is a trademark of Sun Microsystems, Inc.
+#
 
 linuxdir = $(includedir)/linux
 
 if UTILS
-linux_HEADERS = lustre_types.h lustre_user.h
+linux_HEADERS = lustre_user.h
 endif
 
 EXTRA_DIST = lprocfs_status.h lustre_acl.h lustre_debug.h lustre_lib.h \
-     lustre_dlm.h  lustre_handles.h lustre_net.h obd_class.h obd_support.h \
-     lustre_log.h lustre_compat25.h lustre_fsfilt.h lustre_mds.h \
-     obd.h lvfs.h lvfs_linux.h lustre_lite.h lustre_quota.h \
-     lustre_user.h lustre_types.h lustre_patchless_compat.h lustre_intent.h \
-     obd_cksum.h
+       lustre_dlm.h  lustre_handles.h lustre_net.h obd_class.h obd_support.h \
+       lustre_log.h lustre_compat25.h lustre_fsfilt.h lustre_mds.h \
+       obd.h lvfs.h lvfs_linux.h lustre_lite.h lustre_quota.h \
+       lustre_user.h lustre_patchless_compat.h lustre_intent.h