Whamcloud - gitweb
LU-14291 lustre: further cleanup of acl code.
[fs/lustre-release.git] / lustre / include / Makefile.am
index 1a2fa30..a0da174 100644 (file)
@@ -24,7 +24,7 @@
 # Copyright (c) 2001, 2010, Oracle and/or its affiliates. All rights reserved.
 # Use is subject to license terms.
 #
-# Copyright (c) 2012, 2014, Intel Corporation.
+# Copyright (c) 2012, 2017, Intel Corporation.
 #
 
 #
@@ -32,9 +32,9 @@
 # Lustre is a trademark of Sun Microsystems, Inc.
 #
 
-SUBDIRS = lustre uapi/linux
+SUBDIRS = lustre uapi/linux/lustre
 
-DIST_SUBDIRS = lustre uapi/linux
+DIST_SUBDIRS = lustre uapi/linux/lustre
 
 EXTRA_DIST = \
        cl_object.h \
@@ -47,11 +47,11 @@ EXTRA_DIST = \
        lustre_acl.h \
        lustre_barrier.h \
        lustre_compat.h \
-       lustre_debug.h \
+       lustre_crypto.h \
        lustre_disk.h \
        lustre_dlm_flags.h \
        lustre_dlm.h \
-       lustre_eacl.h \
+       lustre_errno.h \
        lustre_export.h \
        lustre_fid.h \
        lustre_fld.h \
@@ -65,10 +65,10 @@ EXTRA_DIST = \
        lustre_linkea.h \
        lustre_lmv.h \
        lustre_log.h \
-       lustre_log_user.h \
        lustre_mdc.h \
        lustre_mds.h \
        lustre_net.h \
+       lustre_osc.h \
        lustre_nodemap.h \
        lustre_nrs.h \
        lustre_nrs_crr.h \
@@ -77,13 +77,12 @@ EXTRA_DIST = \
        lustre_nrs_orr.h \
        lustre_nrs_tbf.h \
        lustre_obdo.h \
-       lustre_patchless_compat.h \
        lustre_quota.h \
        lustre_req_layout.h \
+       lustre_scrub.h \
        lustre_sec.h \
        lustre_swab.h \
        lustre_update.h \
-       lustre_ver.h \
        lu_target.h \
        lvfs.h \
        md_object.h \
@@ -94,7 +93,7 @@ EXTRA_DIST = \
        obd_support.h \
        obd_target.h \
        obj_update.h \
+       range_lock.h \
        upcall_cache.h \
        lustre_kernelcomm.h \
-       seq_range.h \
-       uapi_kernelcomm.h
+       seq_range.h