Whamcloud - gitweb
LU-12189 ec: code to add support for M to N parity
[fs/lustre-release.git] / lustre / include / Makefile.am
index c3eafd7..96795c7 100644 (file)
 #
 # You should have received a copy of the GNU General Public License
 # version 2 along with this program; If not, see
-# http://www.sun.com/software/products/lustre/docs/GPLv2.pdf
-#
-# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
-# CA 95054 USA or visit www.sun.com if you need additional information or
-# have any questions.
+# http://www.gnu.org/licenses/gpl-2.0.html
 #
 # GPL HEADER END
 #
 # Copyright (c) 2001, 2010, Oracle and/or its affiliates. All rights reserved.
 # Use is subject to license terms.
 #
-# Copyright (c) 2012, 2013, Intel Corporation.
+# Copyright (c) 2012, 2017, Intel Corporation.
 #
 
 #
 # This file is part of Lustre, http://www.lustre.org/
-# Lustre is a trademark of Sun Microsystems, Inc.
 #
 
-SUBDIRS = linux lustre
+SUBDIRS = lustre uapi/linux/lustre
 
-DIST_SUBDIRS = linux lustre darwin
+DIST_SUBDIRS = lustre uapi/linux/lustre
 
 EXTRA_DIST = \
        cl_object.h \
        dt_object.h \
+       erasure_code.h \
        interval_tree.h \
-       ioctl.h \
-       lclient.h \
-       liblustre.h \
+       llog_swab.h \
        lprocfs_status.h \
        lu_object.h \
        lu_ref.h \
        lustre_acl.h \
-       lustre_capa.h \
-       lustre_cfg.h \
-       lustre_debug.h \
+       lustre_barrier.h \
+       lustre_compat.h \
+       lustre_crypto.h \
        lustre_disk.h \
        lustre_dlm_flags.h \
        lustre_dlm.h \
-       lustre_eacl.h \
+       lustre_errno.h \
        lustre_export.h \
        lustre_fid.h \
        lustre_fld.h \
-       lustre_fsfilt.h \
        lustre_ha.h \
        lustre_handles.h \
        lustre_idmap.h \
        lustre_import.h \
+       lustre_intent.h \
        lustre_lfsck.h \
        lustre_lib.h \
        lustre_linkea.h \
-       lustre_lite.h \
+       lustre_lmv.h \
        lustre_log.h \
        lustre_mdc.h \
        lustre_mds.h \
        lustre_net.h \
-       lustre_param.h \
+       lustre_osc.h \
+       lustre_nodemap.h \
+       lustre_nrs.h \
+       lustre_nrs_crr.h \
+       lustre_nrs_delay.h \
+       lustre_nrs_fifo.h \
+       lustre_nrs_orr.h \
+       lustre_nrs_tbf.h \
+       lustre_obdo.h \
        lustre_quota.h \
        lustre_req_layout.h \
+       lustre_scrub.h \
        lustre_sec.h \
+       lustre_swab.h \
        lustre_update.h \
-       lustre_ver.h \
        lu_target.h \
        lvfs.h \
        md_object.h \
@@ -87,7 +90,10 @@ EXTRA_DIST = \
        obd_cksum.h \
        obd_class.h \
        obd.h \
-       obd_lov.h \
-       obd_ost.h \
        obd_support.h \
-       obd_target.h
+       obd_target.h \
+       obj_update.h \
+       range_lock.h \
+       upcall_cache.h \
+       lustre_kernelcomm.h \
+       seq_range.h