Whamcloud - gitweb
LU-12189 ec: code to add support for M to N parity
[fs/lustre-release.git] / lustre / include / Makefile.am
index 4613df4..96795c7 100644 (file)
 # Copyright (c) 2001, 2010, Oracle and/or its affiliates. All rights reserved.
 # Use is subject to license terms.
 #
-# Copyright (c) 2012, 2014, Intel Corporation.
+# Copyright (c) 2012, 2017, Intel Corporation.
 #
 
 #
 # This file is part of Lustre, http://www.lustre.org/
-# Lustre is a trademark of Sun Microsystems, Inc.
 #
 
 SUBDIRS = lustre uapi/linux/lustre
@@ -39,6 +38,7 @@ DIST_SUBDIRS = lustre uapi/linux/lustre
 EXTRA_DIST = \
        cl_object.h \
        dt_object.h \
+       erasure_code.h \
        interval_tree.h \
        llog_swab.h \
        lprocfs_status.h \
@@ -47,11 +47,10 @@ EXTRA_DIST = \
        lustre_acl.h \
        lustre_barrier.h \
        lustre_compat.h \
-       lustre_debug.h \
+       lustre_crypto.h \
        lustre_disk.h \
        lustre_dlm_flags.h \
        lustre_dlm.h \
-       lustre_eacl.h \
        lustre_errno.h \
        lustre_export.h \
        lustre_fid.h \
@@ -78,9 +77,9 @@ EXTRA_DIST = \
        lustre_nrs_orr.h \
        lustre_nrs_tbf.h \
        lustre_obdo.h \
-       lustre_patchless_compat.h \
        lustre_quota.h \
        lustre_req_layout.h \
+       lustre_scrub.h \
        lustre_sec.h \
        lustre_swab.h \
        lustre_update.h \
@@ -94,6 +93,7 @@ EXTRA_DIST = \
        obd_support.h \
        obd_target.h \
        obj_update.h \
+       range_lock.h \
        upcall_cache.h \
        lustre_kernelcomm.h \
        seq_range.h