Whamcloud - gitweb
Another slightly less rough cut at XML based configuration. There
[fs/lustre-release.git] / lustre / extN / Makefile.am
index 317cf2c..c34c1cb 100644 (file)
@@ -17,7 +17,7 @@ EXTN_EXTRA = include/linux/xattr.h include/linux/extN_xattr.h fs/extN/xattr.c
 extN_SOURCES = $(EXTNC) $(EXTNI) xattr.c # punch.c
 extN_DEPENDENCIES = patch-stamp
 EXTRA_DIST = $(EXTNP) extN-2.4.18-ino_sb_fixup.diff extN-2.4.18-exports.diff
-DISTCLEANFILES = $(EXTNC) $(EXTNI) patch-stamp *.orig *.rej
+DISTCLEANFILES = $(extN_SOURCES) patch-stamp *.orig *.rej
 SUB=-e "s/ext3/extN/g" -e "s/EXT3/EXTN/g"
 
 include $(top_srcdir)/Rules
@@ -54,7 +54,7 @@ patch-stamp: $(EXTNP)
                patch -p0 < $(srcdir)/extN.patch-$(RELEASE); \
        else \
                list='$(EXTNP)'; for p in $$list; do                        \
-               sed $(SUB) $(srcdir)/$$p | (cd $(top_srcdir); patch -p1);   \
+               sed $(SUB) $(srcdir)/$$p|(cd $(top_srcdir);patch -p1)||exit -1;\
                done;  \
                echo "It is OK if the following patch fails";               \
                (cd $(top_srcdir); patch -N -p1) < $(srcdir)/extN-2.4.18-exports.diff; \