Whamcloud - gitweb
- landing of b_hd_cleanup_merge to HEAD.
[fs/lustre-release.git] / lustre / doc / Makefile.am
index fd5a857..7b58834 100644 (file)
@@ -14,20 +14,31 @@ PS2PDF = ps2pdf
 TEXEXPAND = texexpand
 SUFFIXES = .lin .lyx .pdf .ps .sgml .html .txt .tex .fig .eps .dvi
 
-DOCS = lustre.pdf lustre-HOWTO.txt
-IMAGES := $(patsubst %.fig,%.eps,$(wildcard *.fig))
-#IMAGES =  sys_stat.eps sys_odirect.eps sys_open.eps sys_write.eps sys_mount.eps cache1.eps cache2.eps intermezzocache.eps intermezzofilesys.eps meta.eps metadata1.eps networklayer.eps bigpicture.eps intermezzo.eps mds.eps portals.eps client.eps layering.eps metadata.eps sb.eps cow.eps lockacq.eps obdfs.eps snapsetup.eps dirbodyapi.eps loraid.eps ost.eps updates.eps hotmigrate.eps lustreclusters.eps osthw.eps portals-lib.eps lockqueues.eps lockexample1.eps lockexample2.eps lockexample3.eps lockexample4.eps lockseverity.eps gssapi.eps lovextents.eps cpsd.eps setup-accept.eps authenticate.eps login.eps
+if DOC
+  DOCS = lustre.pdf recovery-manual.pdf
+else
+  DOCS =
+endif
+
+if UTILS
+man_MANS = lfs.1 lmc.1 lwizard.1 lconf.8 lctl.8
+endif
 
-LYXFILES= $(wildcard *.lin) $(wildcard *.lyx)
+
+IMAGES := $(patsubst %.fig,%.eps,$(wildcard *.fig))
+LYXFILES= $(filter-out $(patsubst %.lin,%.lyx,$(wildcard *.lin)),\
+       $(wildcard *.lin *.lyx))
 
 MAINTAINERCLEANFILES =  $(IMAGES) $(DOCS) $(VERSIONED)
 CLEANFILES = *.aux *.tex doc.old/*.aux doc.old/*.tex *.eps *.log *.pdf
-VERSIONED = lustre-HOWTO.lyx lustre.lyx doc.old/lustre-HOWTO.lyx doc.old/lustre.lyx
+VERSIONED = lustre.lyx doc.old/lustre.lyx
 GENERATED = $(VERSIONED) lustre-full.tex lustre-chbar.tex
 
-EXTRA_DIST = chbar.sh postbar tex2pdf $(DOCS) $(IMAGES) $(LYXFILES) lustre.bib
+EXTRA_DIST = chbar.sh postbar tex2pdf $(DOCS) $(man_MANS) $(IMAGES)     \
+        $(LYXFILES) lustre.bib lfs.1 lmc.1 lwizard.1 lconf.8 lctl.8
 
-all: $(DOCS)
+all:
+docs: $(DOCS)
 
 # These variables are set by lbuild/check-build.
 RPMRELEASE ?= RELEASE
@@ -72,7 +83,7 @@ $(VERSIONED) : %.lyx: %.lin Makefile
 .ps.pdf:
        $(PS2PDF) $< $@
 
-lustre.tex lustre.pdf lustre.txt lustre.html: $(IMAGES) $(LYXFILES) lustre-HOWTO.lyx
+lustre.tex recovery-manual.tex lustre.pdf recovery-manual.pdf lustre.txt lustre.html: $(IMAGES) $(LYXFILES)
 .fig.eps:
        -fig2dev -L eps $< > $@
 
@@ -84,18 +95,29 @@ syncweb: lustre.pdf
 # Build a changebar document from the files in doc.old and this directory.
 chbar: lustre-chbar.pdf
 
+# FIXME: Temporary rules until pdftex displays changebars correctly.
+lustre-chbar.pdf: lustre-chbar-nopdf.ps
+       $(PS2PDF) $< $@
+lustre-chbar-nopdf.ps: lustre-chbar-nopdf.dvi
+       $(DVIPS) $< -o $@
+lustre-chbar-nopdf.dvi: lustre-chbar-nopdf.tex
+       $(LATEX) $<
+       $(LATEX) $<
+lustre-chbar-nopdf.tex: lustre-chbar.tex
+       sed -e 's/^\(.*usepackage.*pdftex\)/%\1/' $< > $@
+
 %-chbar.tex: chbar.sh postbar doc.old/%-full.tex %-full.tex
        $(SHELL) $(srcdir)/chbar.sh doc.old/$*-full.tex $*-full.tex | $(srcdir)/postbar > $@
 
-%-full.tex: %.tex
-       $(TEXEXPAND) -texinputs=. -texinputs=$(srcdir) -output=$@ $<
-
-doc.old/lustre.tex: doc.old/lustre-HOWTO.lyx
 doc.old/%-full.tex: doc.old/%.tex
        cd doc.old && $(TEXEXPAND) -texinputs=. -output=$*-full.tex $*.tex
 
+# This rule needs to come after the more specific doc.old rule.
+%-full.tex: %.tex
+       $(TEXEXPAND) -texinputs=. -texinputs=$(srcdir) -output=$@ $<
+
 # Check out the old directory if it doesn't exist.
-doc.old/lustre.lin doc.old/lustre-HOWTO.lin:
+doc.old/lustre.lin:
        @if test "X$(OLD)" = X; then \
          echo "You must populate doc.old or specify a CVS tag like OLD=v0_5_1"; \
          exit 1; \
@@ -106,5 +128,3 @@ doc.old/lustre.lin doc.old/lustre-HOWTO.lin:
 
 dist-hook:
        rm -rf $(distdir)/figs/CVS
-
-include $(top_srcdir)/Rules