Whamcloud - gitweb
- landing of b_hd_cleanup_merge to HEAD.
[fs/lustre-release.git] / lustre / doc / Makefile.am
index dce1343..7b58834 100644 (file)
@@ -20,6 +20,11 @@ else
   DOCS =
 endif
 
+if UTILS
+man_MANS = lfs.1 lmc.1 lwizard.1 lconf.8 lctl.8
+endif
+
+
 IMAGES := $(patsubst %.fig,%.eps,$(wildcard *.fig))
 LYXFILES= $(filter-out $(patsubst %.lin,%.lyx,$(wildcard *.lin)),\
        $(wildcard *.lin *.lyx))
@@ -29,7 +34,8 @@ CLEANFILES = *.aux *.tex doc.old/*.aux doc.old/*.tex *.eps *.log *.pdf
 VERSIONED = lustre.lyx doc.old/lustre.lyx
 GENERATED = $(VERSIONED) lustre-full.tex lustre-chbar.tex
 
-EXTRA_DIST = chbar.sh postbar tex2pdf $(DOCS) $(IMAGES) $(LYXFILES) lustre.bib
+EXTRA_DIST = chbar.sh postbar tex2pdf $(DOCS) $(man_MANS) $(IMAGES)     \
+        $(LYXFILES) lustre.bib lfs.1 lmc.1 lwizard.1 lconf.8 lctl.8
 
 all:
 docs: $(DOCS)