Whamcloud - gitweb
windows porting: add private lnet tag to b_winnt_port branch
[fs/lustre-release.git] / lustre / doc / Makefile.am
index af77aa3..2e1910c 100644 (file)
@@ -1,39 +1,64 @@
-# Copyright (C) 2001  Cluster File Systems, Inc.
+# Copyright (C) 2001, 2002 Cluster File Systems, Inc.
 #
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
-LYX2PDF = lyx --export pdf
+LYX2PDF = GS_OPTIONS=-dCompatibilityLevel=1.1 $(srcdir)/tex2pdf -overwrite
+TEX2PDF = GS_OPTIONS=-dCompatibilityLevel=1.1 $(srcdir)/tex2pdf -overwrite
+LYX2PS = lyx --export ps
+LYX2TEX = lyx --export latex
 LYX2TXT = lyx --export text
 LYX2HTML = lyx --export html
-SUFFIXES = .lyx .pdf .sgml .html .txt .fig .eps
+LATEX = latex
+DVIPS = dvips
+PS2PDF = ps2pdf
+TEXEXPAND = texexpand
+SUFFIXES = .lin .lyx .pdf .ps .sgml .html .txt .tex .fig .eps .dvi
 
-DOCS = master.pdf lustre-HOWTO.txt
-IMAGES = networklayer.fig bigpicture.eps intermezzo.eps mds.eps portals.eps client.eps layering.eps metadata.eps sb.eps cow.eps lockacq.eps obdfs.eps snapsetup.eps dirbodyapi.eps loraid.eps ost.eps updates.eps hotmigrate.eps lustreclusters.eps osthw.eps portals-lib.eps lockqueues.eps lockexample1.eps lockexample2.eps lockexample3.eps lockexample4.eps lockseverity.eps
-CLEANFILES = $(IMAGES) $(DOCS)
+MANFILES = lustre.7 lfs.1 mount.lustre.8 mkfs.lustre.8 tunefs.lustre.8 lctl.8 \
+       llverdev.8 llbackup.8
 
-EXTRA_DIST = $(DOCS)
+if UTILS
+man_MANS = $(MANFILES)
+endif
 
-all: $(DOCS)
+LYXFILES= $(filter-out $(patsubst %.lin,%.lyx,$(wildcard *.lin)),\
+       $(wildcard *.lin *.lyx))
+
+CLEANFILES = *.aux *.tex *.log *.pdf
+
+EXTRA_DIST = tex2pdf $(MANFILES) $(LYXFILES)
+
+all:
+
+# These variables are set by lbuild/check-build.
+RPMRELEASE ?= RELEASE
+KERNTYPE ?= chaos
+KERNRPM ?= kernel-2.4.18lustre13-RELEASE.i386.rpm
 
 .lyx.pdf:
-       @$(LYX2PDF) $< || printf "\n*** Warning: not creating PDF docs; install lyx to rectify this\n"
+       @echo $(LYX2PDF) $< && $(LYX2PDF) $< || printf "\n*** Warning: not creating PDF docs; install lyx to rectify this\n"
+
+.lyx.ps:
+       @echo $(LYX2PS) $< && $(LYX2PS) $< || printf "\n*** Warning: not creating PostScript docs; install lyx to rectify this\n"
+
+.lyx.tex:
+       @echo $(LYX2TEX) $< && $(LYX2TEX) $< || printf "\n*** Warning: not creating LaTeX docs; install lyx to rectify this\n"
 
 .lyx.txt:
-       @$(LYX2TXT) $< || printf "\n*** Warning: not creating PDF docs; install lyx to rectify this\n"
+       @echo $(LYX2TXT) $< && $(LYX2TXT) $< || printf "\n*** Warning: not creating text docs; install lyx to rectify this\n"
 
 .lyx.html:
-       @$(LYX2HTML) $< || printf "\n*** Warning: not creating PDF docs; install lyx to rectify this\n"
-
-.fig.eps:
-       -fig2dev -L eps $< > $@
+       @echo $(LYX2HTML) $< && $(LYX2HTML) $< || printf "\n*** Warning: not creating HTML docs; install lyx to rectify this\n"
 
-master.pdf: master.lyx $(IMAGES)
+.tex.pdf:
+       $(TEX2PDF) $<
 
-syncweb: master.pdf
-       cp master.pdf /usr/src/www/content/lustre/docs/master.pdf
-       ( cd /usr/src/www ; make lustre ; make synclustre )
+.tex.dvi:
+       $(LATEX) $<
+       $(LATEX) $<
 
-dist-hook:
-       rm -rf $(distdir)/figs/CVS
+.dvi.ps:
+       $(DVIPS) $< -o $@
 
-include $(top_srcdir)/Rules
+.ps.pdf:
+       $(PS2PDF) $< $@