Whamcloud - gitweb
land b1_5 onto HEAD
[fs/lustre-release.git] / lustre / doc / Makefile.am
index c93427c..1d02c60 100644 (file)
@@ -14,47 +14,25 @@ PS2PDF = ps2pdf
 TEXEXPAND = texexpand
 SUFFIXES = .lin .lyx .pdf .ps .sgml .html .txt .tex .fig .eps .dvi
 
-if DOC
-  DOCS = lustre.pdf recovery-manual.pdf
-else
-  DOCS =
-endif
-
 if UTILS
-man_MANS = lfs.1 lmc.1 lwizard.1 lconf.8 lctl.8
+man_MANS = lustre.7 lfs.1 mount.lustre.8 mkfs.lustre.8 tunefs.lustre.8 lctl.8 
 endif
 
-
-IMAGES := $(patsubst %.fig,%.eps,$(wildcard *.fig))
 LYXFILES= $(filter-out $(patsubst %.lin,%.lyx,$(wildcard *.lin)),\
        $(wildcard *.lin *.lyx))
 
-MAINTAINERCLEANFILES =  $(IMAGES) $(DOCS) $(VERSIONED)
-CLEANFILES = *.aux *.tex doc.old/*.aux doc.old/*.tex *.eps *.log *.pdf
-VERSIONED = lustre.lyx doc.old/lustre.lyx
-GENERATED = $(VERSIONED) lustre-full.tex lustre-chbar.tex
+CLEANFILES = *.aux *.tex *.log *.pdf
 
-EXTRA_DIST = chbar.sh postbar tex2pdf $(DOCS) $(man_MANS) $(IMAGES)     \
-        $(LYXFILES) lfs.1 lmc.1 lwizard.1 lconf.8 lctl.8
+EXTRA_DIST = tex2pdf lustre.7 mount.lustre.8 mkfs.lustre.8 tunefs.lustre.8 \
+       $(LYXFILES) lfs.1 lctl.8        
 
 all:
-docs: $(DOCS)
 
 # These variables are set by lbuild/check-build.
 RPMRELEASE ?= RELEASE
 KERNTYPE ?= chaos
 KERNRPM ?= kernel-2.4.18lustre13-RELEASE.i386.rpm
 
-# update date and version in document
-date := $(shell date +%x)
-tag := $(shell echo '$$Name:  $$' | sed -e 's/^\$$Na''me: *\$$$$/HEAD/; s/^\$$Na''me: \(.*\) \$$$$/\1/')
-addversion = sed -e 's|@T''AG@|$(tag)|g; s|@VER''SION@|$(VERSION)|g; s|@DA''TE@|$(date)|g; s|@RPM''RELEASE@|$(RPMRELEASE)|g; s|@KERN''TYPE@|$(KERNTYPE)|g; s|@KERN''RPM@|$(KERNRPM)|g'
-
-# Regenerate when the $(VERSION) or $Name:  $ changes.
-.INTERMEDIATE: $(GENERATED)
-$(VERSIONED) : %.lyx: %.lin Makefile
-       $(addversion) $< > $@
-
 .lyx.pdf:
        @echo $(LYX2PDF) $< && $(LYX2PDF) $< || printf "\n*** Warning: not creating PDF docs; install lyx to rectify this\n"
 
@@ -82,49 +60,3 @@ $(VERSIONED) : %.lyx: %.lin Makefile
 
 .ps.pdf:
        $(PS2PDF) $< $@
-
-lustre.tex recovery-manual.tex lustre.pdf recovery-manual.pdf lustre.txt lustre.html: $(IMAGES) $(LYXFILES)
-.fig.eps:
-       -fig2dev -L eps $< > $@
-
-syncweb: lustre.pdf
-       cp lustre.pdf /usr/src/www/content/lustre/docs/lustre.pdf
-       ( cd /usr/src/www ; make lustre ; make synclustre )
-.PHONY: syncweb chbar
-
-# Build a changebar document from the files in doc.old and this directory.
-chbar: lustre-chbar.pdf
-
-# FIXME: Temporary rules until pdftex displays changebars correctly.
-lustre-chbar.pdf: lustre-chbar-nopdf.ps
-       $(PS2PDF) $< $@
-lustre-chbar-nopdf.ps: lustre-chbar-nopdf.dvi
-       $(DVIPS) $< -o $@
-lustre-chbar-nopdf.dvi: lustre-chbar-nopdf.tex
-       $(LATEX) $<
-       $(LATEX) $<
-lustre-chbar-nopdf.tex: lustre-chbar.tex
-       sed -e 's/^\(.*usepackage.*pdftex\)/%\1/' $< > $@
-
-%-chbar.tex: chbar.sh postbar doc.old/%-full.tex %-full.tex
-       $(SHELL) $(srcdir)/chbar.sh doc.old/$*-full.tex $*-full.tex | $(srcdir)/postbar > $@
-
-doc.old/%-full.tex: doc.old/%.tex
-       cd doc.old && $(TEXEXPAND) -texinputs=. -output=$*-full.tex $*.tex
-
-# This rule needs to come after the more specific doc.old rule.
-%-full.tex: %.tex
-       $(TEXEXPAND) -texinputs=. -texinputs=$(srcdir) -output=$@ $<
-
-# Check out the old directory if it doesn't exist.
-doc.old/lustre.lin:
-       @if test "X$(OLD)" = X; then \
-         echo "You must populate doc.old or specify a CVS tag like OLD=v0_5_1"; \
-         exit 1; \
-       fi
-       rm -rf doc.old
-       mkdir doc.old
-       cvs checkout -r $(OLD) -d doc.old lustre/doc
-
-dist-hook:
-       rm -rf $(distdir)/figs/CVS