Whamcloud - gitweb
LU-7668 utils: add lctl del_ost
[fs/lustre-release.git] / lustre / doc / Makefile.am
index 2896ba2..0da96cd 100644 (file)
@@ -29,7 +29,6 @@
 
 #
 # This file is part of Lustre, http://www.lustre.org/
-# Lustre is a trademark of Sun Microsystems, Inc.
 #
 
 MANFILES =                                     \
@@ -38,8 +37,8 @@ MANFILES =                                    \
        lctl-list_param.8                       \
        lctl-network.8                          \
        lctl-pcc.8                              \
-       lctl-pool_add.8                 \
-       lctl-pool_new.8                 \
+       lctl-pool_add.8                         \
+       lctl-pool_new.8                         \
        lctl-set_param.8                        \
        ldev.8                                  \
        ldev.conf.5                             \
@@ -47,12 +46,17 @@ MANFILES =                                  \
        lfs-df.1                                \
        lfs-fid2path.1                          \
        lfs-find.1                              \
+       lfs-flushctx.1                          \
        lfs-getdirstripe.1                      \
        lfs-getname.1                           \
        lfs-getsom.1                            \
-       lfs-getstripe.1                 \
+       lfs-getstripe.1                         \
        lfs-heat.1                              \
        lfs-hsm.1                               \
+       lfs-hsm_action.1                        \
+       lfs-hsm_clear.1                         \
+       lfs-hsm_set.1                           \
+       lfs-hsm_state.1                         \
        lfs-ladvise.1                           \
        lfs_migrate.1                           \
        lfs-migrate.1                           \
@@ -67,18 +71,33 @@ MANFILES =                                  \
        lfs-mirror-write.1                      \
        lfs-mkdir.1                             \
        lfs-path2fid.1                          \
-       lfs-pcc.1                               \
        lfs-pcc-detach.1                        \
+       lfs-pcc.1                               \
        lfs-project.1                           \
        lfs-quota.1                             \
        lfs-rmfid.1                             \
        lfs-setdirstripe.1                      \
        lfs-setquota.1                          \
        lfs-setstripe.1                         \
-       l_getidentity.8                         \
-       l_getsepol.8                            \
        lgss_sk.8                               \
        lhbadm.8                                \
+       ll_decode_linkea.8                      \
+       llsom_sync.8                            \
+       llstat.8                                \
+       lnetctl.8                               \
+       lst.8                                   \
+       lustre.7                                \
+       lustre_routes_config.8                  \
+       lustre_routes_conversion.8              \
+       lustre_rsync.8                          \
+       mount.lustre.8                          \
+       nids.5                                  \
+       plot-llstat.8                           \
+       routerstat.8
+
+
+LIBMAN =                                       \
+       lustreapi.7                             \
        llapi_create_volatile_param.3           \
        llapi_fd2parent.3                       \
        llapi_fid_parse.3                       \
@@ -153,7 +172,7 @@ MANFILES =                                  \
        llapi_pcc_detach_fid.3                  \
        llapi_pcc_detach_fid_fd.3               \
        llapi_pcc_detach_fid_str.3              \
-       llapi_pcc_detach_file.3         \
+       llapi_pcc_detach_file.3                 \
        llapi_pccdev_get.3                      \
        llapi_pccdev_set.3                      \
        llapi_pcc_state_get.3                   \
@@ -163,26 +182,14 @@ MANFILES =                                        \
        llapi_search_mdt.3                      \
        llapi_search_ost.3                      \
        llapi_search_tgt.3                      \
-       ll_decode_linkea.8                      \
-       llobdstat.8                             \
-       llog_reader.8                           \
-       llsom_sync.8                            \
-       llstat.8                                \
-       lnetctl.8                               \
-       lst.8                                   \
-       lustre.7                                \
-       lustreapi.7                             \
-       lustre_routes_config.8                  \
-       lustre_routes_conversion.8              \
-       lustre_rsync.8                          \
-       mount.lustre.8                          \
-       mount.lustre_tgt.8                      \
-       nids.5                                  \
-       plot-llstat.8                           \
-       routerstat.8
+       llapi_unlink_foreign.3
 
 SERVER_MANFILES =                              \
+       l_getidentity.8                         \
+       l_getsepol.8                            \
        lctl-barrier.8                          \
+       lctl-changelog_deregister.8             \
+       lctl-changelog_register.8               \
        lctl-lcfg.8                             \
        lctl-lfsck-query.8                      \
        lctl-lfsck-start.8                      \
@@ -191,13 +198,14 @@ SERVER_MANFILES =                         \
        lctl-llog_catlist.8                     \
        lctl-llog_info.8                        \
        lctl-llog_print.8                       \
+       lctl-del_ost.8                          \
        lctl-nodemap-activate.8                 \
-       lctl-nodemap-add.8                      \
        lctl-nodemap-add-idmap.8                \
        lctl-nodemap-add-range.8                \
-       lctl-nodemap-del.8                      \
+       lctl-nodemap-add.8                      \
        lctl-nodemap-del-idmap.8                \
        lctl-nodemap-del-range.8                \
+       lctl-nodemap-del.8                      \
        lctl-nodemap-modify.8                   \
        lctl-nodemap-set-fileset.8              \
        lctl-nodemap-set-sepol.8                \
@@ -208,25 +216,27 @@ SERVER_MANFILES =                         \
        lctl-snapshot-mount.8                   \
        lctl-snapshot-umount.8                  \
        ll_decode_filter_fid.8                  \
+       llobdstat.8                             \
+       llog_reader.8                           \
        llverdev.8                              \
        lshowmount.8                            \
        mkfs.lustre.8                           \
+       mount.lustre_tgt.8                      \
        tunefs.lustre.8
 
+if MANPAGES
+man_MANS = $(LIBMAN)
 if SERVER
-MANFILES += $(SERVER_MANFILES)
-else
-DISTONLY_MANFILES = $(SERVER_MANFILES)
+man_MANS += $(SERVER_MANFILES)
 endif
 
 if UTILS
-if MANPAGES
-man_MANS = $(MANFILES)
+man_MANS += $(MANFILES)
 endif
 endif
 
 CLEANFILES = *.aux *.tex *.log *.pdf
 
-EXTRA_DIST = $(MANFILES) $(DISTONLY_MANFILES)
+EXTRA_DIST = $(MANFILES) $(SERVER_MANFILES) $(LIBMAN)
 
 all: