Whamcloud - gitweb
b=19047
[fs/lustre-release.git] / lustre / doc / Makefile.am
index 8302275..0a79a29 100644 (file)
@@ -1,7 +1,39 @@
-# Copyright (C) 2001, 2002 Cluster File Systems, Inc.
 #
-# This code is issued under the GNU General Public License.
-# See the file COPYING in this distribution
+# GPL HEADER START
+#
+# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2 only,
+# as published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# General Public License version 2 for more details (a copy is included
+# in the LICENSE file that accompanied this code).
+#
+# You should have received a copy of the GNU General Public License
+# version 2 along with this program; If not, see
+# http://www.sun.com/software/products/lustre/docs/GPLv2.pdf
+#
+# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
+# CA 95054 USA or visit www.sun.com if you need additional information or
+# have any questions.
+#
+# GPL HEADER END
+#
+
+#
+# Copyright  2008 Sun Microsystems, Inc. All rights reserved
+# Use is subject to license terms.
+#
+
+#
+# This file is part of Lustre, http://www.lustre.org/
+# Lustre is a trademark of Sun Microsystems, Inc.
+#
+
 LYX2PDF = GS_OPTIONS=-dCompatibilityLevel=1.1 $(srcdir)/tex2pdf -overwrite
 TEX2PDF = GS_OPTIONS=-dCompatibilityLevel=1.1 $(srcdir)/tex2pdf -overwrite
 LYX2PS = lyx --export ps
@@ -14,43 +46,29 @@ PS2PDF = ps2pdf
 TEXEXPAND = texexpand
 SUFFIXES = .lin .lyx .pdf .ps .sgml .html .txt .tex .fig .eps .dvi
 
-if DOC
-  DOCS = lustre.pdf lustre-HOWTO.txt
-  HOWTODOC = lustre-HOWTO.txt
-else
-  DOCS =
-  HOWTODOC =
+MANFILES = lustre.7 lfs.1 mount.lustre.8 mkfs.lustre.8 tunefs.lustre.8 lctl.8 \
+       llverdev.8 llbackup.8 llapi_quotactl.3 llobdstat.8 llstat.8 \
+       plot-llstat.8 l_getgroups.8 lst.8 routerstat.8 \
+       ll_recover_lost_found_objs.8 llog_reader.8
+
+if UTILS
+man_MANS = $(MANFILES)
 endif
 
-IMAGES := $(patsubst %.fig,%.eps,$(wildcard *.fig))
 LYXFILES= $(filter-out $(patsubst %.lin,%.lyx,$(wildcard *.lin)),\
        $(wildcard *.lin *.lyx))
 
-MAINTAINERCLEANFILES =  $(IMAGES) $(DOCS) $(VERSIONED)
-CLEANFILES = *.aux *.tex doc.old/*.aux doc.old/*.tex *.eps *.log *.pdf
-VERSIONED = lustre-HOWTO.lyx lustre.lyx doc.old/lustre-HOWTO.lyx doc.old/lustre.lyx
-GENERATED = $(VERSIONED) lustre-full.tex lustre-chbar.tex
+CLEANFILES = *.aux *.tex *.log *.pdf
 
-EXTRA_DIST = chbar.sh postbar tex2pdf $(DOCS) $(IMAGES) $(LYXFILES) lustre.bib
+EXTRA_DIST = tex2pdf $(MANFILES) $(LYXFILES)
 
-all: $(HOWTODOC)
-docs: $(DOCS)
+all:
 
 # These variables are set by lbuild/check-build.
 RPMRELEASE ?= RELEASE
 KERNTYPE ?= chaos
 KERNRPM ?= kernel-2.4.18lustre13-RELEASE.i386.rpm
 
-# update date and version in document
-date := $(shell date +%x)
-tag := $(shell echo '$$Name:  $$' | sed -e 's/^\$$Na''me: *\$$$$/HEAD/; s/^\$$Na''me: \(.*\) \$$$$/\1/')
-addversion = sed -e 's|@T''AG@|$(tag)|g; s|@VER''SION@|$(VERSION)|g; s|@DA''TE@|$(date)|g; s|@RPM''RELEASE@|$(RPMRELEASE)|g; s|@KERN''TYPE@|$(KERNTYPE)|g; s|@KERN''RPM@|$(KERNRPM)|g'
-
-# Regenerate when the $(VERSION) or $Name:  $ changes.
-.INTERMEDIATE: $(GENERATED)
-$(VERSIONED) : %.lyx: %.lin Makefile
-       $(addversion) $< > $@
-
 .lyx.pdf:
        @echo $(LYX2PDF) $< && $(LYX2PDF) $< || printf "\n*** Warning: not creating PDF docs; install lyx to rectify this\n"
 
@@ -78,53 +96,3 @@ $(VERSIONED) : %.lyx: %.lin Makefile
 
 .ps.pdf:
        $(PS2PDF) $< $@
-
-lustre.tex lustre.pdf lustre.txt lustre.html: $(IMAGES) $(LYXFILES) lustre-HOWTO.lyx
-.fig.eps:
-       -fig2dev -L eps $< > $@
-
-syncweb: lustre.pdf
-       cp lustre.pdf /usr/src/www/content/lustre/docs/lustre.pdf
-       ( cd /usr/src/www ; make lustre ; make synclustre )
-.PHONY: syncweb chbar
-
-# Build a changebar document from the files in doc.old and this directory.
-chbar: lustre-chbar.pdf
-
-# FIXME: Temporary rules until pdftex displays changebars correctly.
-lustre-chbar.pdf: lustre-chbar-nopdf.ps
-       $(PS2PDF) $< $@
-lustre-chbar-nopdf.ps: lustre-chbar-nopdf.dvi
-       $(DVIPS) $< -o $@
-lustre-chbar-nopdf.dvi: lustre-chbar-nopdf.tex
-       $(LATEX) $<
-       $(LATEX) $<
-lustre-chbar-nopdf.tex: lustre-chbar.tex
-       sed -e 's/^\(.*usepackage.*pdftex\)/%\1/' $< > $@
-
-%-chbar.tex: chbar.sh postbar doc.old/%-full.tex %-full.tex
-       $(SHELL) $(srcdir)/chbar.sh doc.old/$*-full.tex $*-full.tex | $(srcdir)/postbar > $@
-
-# This rule needs to come before the next %-full.tex rule.
-doc.old/lustre.tex: doc.old/lustre-HOWTO.lyx
-doc.old/%-full.tex: doc.old/%.tex
-       cd doc.old && $(TEXEXPAND) -texinputs=. -output=$*-full.tex $*.tex
-
-# This rule needs to come after the more specific doc.old rule.
-%-full.tex: %.tex
-       $(TEXEXPAND) -texinputs=. -texinputs=$(srcdir) -output=$@ $<
-
-# Check out the old directory if it doesn't exist.
-doc.old/lustre.lin doc.old/lustre-HOWTO.lin:
-       @if test "X$(OLD)" = X; then \
-         echo "You must populate doc.old or specify a CVS tag like OLD=v0_5_1"; \
-         exit 1; \
-       fi
-       rm -rf doc.old
-       mkdir doc.old
-       cvs checkout -r $(OLD) -d doc.old lustre/doc
-
-dist-hook:
-       rm -rf $(distdir)/figs/CVS
-
-include $(top_srcdir)/Rules