Whamcloud - gitweb
Fix truncate-vs-write corruption - truncate wasn't marking the last partial
[fs/lustre-release.git] / lustre / configure.in
index c60f868..4107a0c 100644 (file)
@@ -23,7 +23,7 @@ AC_ARG_ENABLE(doc, [  --disable-doc skip creation of pdf documentation],
                            ENABLE_DOC=0
                        fi
                   ],
-                  [ ENABLE_DOC=1 ])
+                  [ ENABLE_DOC=0 ])
 AM_CONDITIONAL(DOC, test x$ENABLE_DOC = x1)
 AC_SUBST(ENABLE_DOC)
 
@@ -33,12 +33,6 @@ if test x$enable_pinger != xno ; then
   AC_DEFINE(ENABLE_PINGER, 1, Use the Pinger)
 fi
 
-# very experimental orphan support
-AC_ARG_ENABLE(orphans, [  --enable-orphans very experimental orphan recovery support])
-if test x$enable_orphans = xyes ; then
-  AC_DEFINE(ENABLE_ORPHANS, 1, Compile with orphan support)
-fi
-
 AC_ARG_WITH(obd-buffer-size, [  --with-obd-buffer-size=[size] set lctl ioctl maximum bytes (default=8192)],OBD_BUFFER_SIZE=$with_obd_buffer_size,OBD_BUFFER_SIZE=8192)
 AC_DEFINE_UNQUOTED(OBD_MAX_IOCTL_BUFFER, $OBD_BUFFER_SIZE, [IOCTL Buffer Size])
 
@@ -55,6 +49,11 @@ AC_SUBST(SYSIO)
 AC_ARG_ENABLE(snapfs, [ --enable-snapfs build snapfs])
 AM_CONDITIONAL(SNAPFS, test x$enable_snapfs = xyes)
 
+# smfs compilation 
+AC_ARG_ENABLE(smfs, [ --enable-smfs build smfs])
+AM_CONDITIONAL(SMFS, test x$enable_smfs = xyes)
+
+
 
 sinclude(portals/build.m4)
 sinclude(portals/archdep.m4)
@@ -78,6 +77,6 @@ AC_OUTPUT([Makefile lvfs/Makefile portals/Makefile portals/Kernelenv \
          lov/Makefile osc/Makefile mdc/Makefile mds/Makefile ost/Makefile \
          cobd/Makefile ptlbd/Makefile conf/Makefile  tests/Makefile \
          utils/Makefile utils/Lustre/Makefile obdfilter/Makefile \
-          obdclass/Makefile snapfs/Makefile snapfs/utils/Makefile \
+          obdclass/Makefile smfs/Makefile snapfs/Makefile snapfs/utils/Makefile \
          include/Makefile include/linux/Makefile llite/Makefile doc/Makefile scripts/Makefile \
          scripts/lustre.spec])