Whamcloud - gitweb
get rid of --smfs-enable options after merge in HEAD
[fs/lustre-release.git] / lustre / configure.in
index 88b11e9..3373fd0 100644 (file)
@@ -17,6 +17,14 @@ AC_ARG_ENABLE([modules],
 AC_MSG_RESULT([$enable_modules])
 AM_CONDITIONAL(MODULES, test x$enable_modules = xyes)
 
+AC_MSG_CHECKING([whether to build Lustre library])
+AC_ARG_ENABLE([liblustre],
+       AC_HELP_STRING([--disable-liblustre],
+                       [disable building of Lustre library]),
+       [],[enable_liblustre='yes'])
+AC_MSG_RESULT([$enable_liblustre])
+AM_CONDITIONAL(LIBLUSTRE, test x$enable_liblustre = xyes)
+
 AC_MSG_CHECKING([whether to build utilities])
 AC_ARG_ENABLE([utils],
        AC_HELP_STRING([--disable-utils],
@@ -31,14 +39,6 @@ AC_ARG_ENABLE([tests],
        [],[enable_tests='yes'])
 AC_MSG_RESULT([$enable_tests])
 
-AC_MSG_CHECKING([whether to build Lustre library])
-AC_ARG_ENABLE([liblustre],
-       AC_HELP_STRING([--disable-liblustre],
-                       [disable building of Lustre library]),
-       [],[enable_liblustre='yes'])
-AC_MSG_RESULT([$enable_liblustre])
-AM_CONDITIONAL(LIBLUSTRE, test x$enable_liblustre = xyes)
-
 # specify wether to build doc or not
 AC_MSG_CHECKING([whether to build docs])
 AC_ARG_ENABLE(doc,
@@ -113,10 +113,19 @@ AC_ARG_WITH([sysio],
                        [set path to libsysio source (default=../libsysio)]),
        [
                SYSIO=$with_sysio
+               SYSIO_PATH=$SYSIO
        ],[
                SYSIO='$(top_srcdir)/../libsysio'
+               SYSIO_PATH='../libsysio'
+       ])
+AC_MSG_RESULT([$SYSIO_PATH])
+
+AC_CHECK_FILE([$SYSIO_PATH/src/libsysio.a],[],
+       [
+               if test x$enable_liblustre = xyes ; then
+                  AC_MSG_ERROR([A built libsysio tree is required for building liblustre.])
+               fi
        ])
-AC_MSG_RESULT([$SYSIO])
 AC_SUBST(SYSIO)
 
 #build mpi-tests 
@@ -137,15 +146,6 @@ AC_ARG_ENABLE([snapfs],
 AC_MSG_RESULT([$enable_snapfs])
 AM_CONDITIONAL(SNAPFS, test x$enable_snapfs = xyes)
 
-# smfs compilation
-AC_MSG_CHECKING([whether to enable smfs support])
-AC_ARG_ENABLE([smfs],
-       AC_HELP_STRING([--enable-smfs],
-                       [build smfs]),
-       [],[enable_smfs='no'])
-AC_MSG_RESULT([$enable_smfs])
-AM_CONDITIONAL(SMFS, test x$enable_smfs = xyes)
-
 sinclude(portals/build.m4)
 sinclude(portals/archdep.m4)
 
@@ -162,18 +162,16 @@ AC_SUBST(INCLUDE_RULES)
 LUSTRE="$PWD"
 AC_SUBST(LUSTRE)
 
-# cray portals turns these off
+#
 AM_CONDITIONAL(UTILS, test x$enable_utils = xyes)
 AM_CONDITIONAL(TESTS, test x$enable_tests = xyes)
 
 AM_CONFIG_HEADER(include/config.h)
 
-# files that are in AC_OUTPUT but need to be executable
-AC_CONFIG_COMMANDS([chmod-lconf],[chmod +x utils/lconf])
-
 AC_OUTPUT([
 Makefile
 Rules
+autoMakefile
 cobd/Makefile
 cobd/autoMakefile
 conf/Makefile
@@ -190,6 +188,8 @@ llite/Makefile
 llite/autoMakefile
 lov/Makefile
 lov/autoMakefile
+lmv/Makefile
+lmv/autoMakefile
 lvfs/Makefile
 lvfs/autoMakefile
 mdc/Makefile
@@ -208,16 +208,16 @@ ost/Makefile
 ost/autoMakefile
 portals/Kernelenv
 portals/Makefile
+portals/autoMakefile
 portals/doc/Makefile
 portals/knals/Makefile
+portals/knals/autoMakefile
 portals/knals/gmnal/Makefile
 portals/knals/gmnal/autoMakefile
 portals/knals/ibnal/Makefile
 portals/knals/ibnal/autoMakefile
 portals/knals/qswnal/Makefile
 portals/knals/qswnal/autoMakefile
-portals/knals/scimacnal/Makefile
-portals/knals/scimacnal/autoMakefile
 portals/knals/socknal/Makefile
 portals/knals/socknal/autoMakefile
 portals/libcfs/Makefile
@@ -242,8 +242,9 @@ smfs/autoMakefile
 snapfs/Makefile
 snapfs/autoMakefile
 snapfs/utils/Makefile
+cmobd/Makefile
+cmobd/autoMakefile
 tests/Makefile
 utils/Lustre/Makefile
 utils/Makefile
-utils/lconf
 ])