Whamcloud - gitweb
get rid of --smfs-enable options after merge in HEAD
[fs/lustre-release.git] / lustre / configure.in
index 47977cc..3373fd0 100644 (file)
@@ -17,6 +17,14 @@ AC_ARG_ENABLE([modules],
 AC_MSG_RESULT([$enable_modules])
 AM_CONDITIONAL(MODULES, test x$enable_modules = xyes)
 
+AC_MSG_CHECKING([whether to build Lustre library])
+AC_ARG_ENABLE([liblustre],
+       AC_HELP_STRING([--disable-liblustre],
+                       [disable building of Lustre library]),
+       [],[enable_liblustre='yes'])
+AC_MSG_RESULT([$enable_liblustre])
+AM_CONDITIONAL(LIBLUSTRE, test x$enable_liblustre = xyes)
+
 AC_MSG_CHECKING([whether to build utilities])
 AC_ARG_ENABLE([utils],
        AC_HELP_STRING([--disable-utils],
@@ -112,36 +120,13 @@ AC_ARG_WITH([sysio],
        ])
 AC_MSG_RESULT([$SYSIO_PATH])
 
-AC_MSG_CHECKING([libsysio exists and ready for use])
-
-if test -r $SYSIO_PATH/src/libsysio.a; then
-       valid_libsysio=yes
-       AC_MSG_RESULT([yes])
-       AC_SUBST(SYSIO)
-else
-       valid_libsysio=no
-       AC_MSG_RESULT([no])
-fi
-
-AC_MSG_CHECKING([whether to build Lustre library])
-AC_ARG_ENABLE([liblustre],
-       AC_HELP_STRING([--disable-liblustre],
-                       [disable building of Lustre library]),
-       [],[enable_liblustre='yes'])
-
-if test x$valid_libsysio != xyes; then
-       enable_liblustre=no
-       AC_MSG_RESULT([$enable_liblustre])
-       
-       echo "Nevertheless liblustre was enabled for build, \
-no valid libsysio is found and liblustre building will be \
-disabled. Make sure that valid libsysio exists and built \
-at $SYSIO_PATH."
-else
-       AC_MSG_RESULT([$enable_liblustre])
-fi
-
-AM_CONDITIONAL(LIBLUSTRE, test x$enable_liblustre = xyes)
+AC_CHECK_FILE([$SYSIO_PATH/src/libsysio.a],[],
+       [
+               if test x$enable_liblustre = xyes ; then
+                  AC_MSG_ERROR([A built libsysio tree is required for building liblustre.])
+               fi
+       ])
+AC_SUBST(SYSIO)
 
 #build mpi-tests 
 AC_MSG_CHECKING([whether to build mpitests])
@@ -161,15 +146,6 @@ AC_ARG_ENABLE([snapfs],
 AC_MSG_RESULT([$enable_snapfs])
 AM_CONDITIONAL(SNAPFS, test x$enable_snapfs = xyes)
 
-# smfs compilation
-AC_MSG_CHECKING([whether to enable smfs support])
-AC_ARG_ENABLE([smfs],
-       AC_HELP_STRING([--enable-smfs],
-                       [build smfs]),
-       [],[enable_smfs='no'])
-AC_MSG_RESULT([$enable_smfs])
-AM_CONDITIONAL(SMFS, test x$enable_smfs = xyes)
-
 sinclude(portals/build.m4)
 sinclude(portals/archdep.m4)
 
@@ -186,18 +162,16 @@ AC_SUBST(INCLUDE_RULES)
 LUSTRE="$PWD"
 AC_SUBST(LUSTRE)
 
-# cray portals turns these off
+#
 AM_CONDITIONAL(UTILS, test x$enable_utils = xyes)
 AM_CONDITIONAL(TESTS, test x$enable_tests = xyes)
 
 AM_CONFIG_HEADER(include/config.h)
 
-# files that are in AC_OUTPUT but need to be executable
-AC_CONFIG_COMMANDS([chmod-lconf],[chmod +x utils/lconf])
-
 AC_OUTPUT([
 Makefile
 Rules
+autoMakefile
 cobd/Makefile
 cobd/autoMakefile
 conf/Makefile
@@ -214,6 +188,8 @@ llite/Makefile
 llite/autoMakefile
 lov/Makefile
 lov/autoMakefile
+lmv/Makefile
+lmv/autoMakefile
 lvfs/Makefile
 lvfs/autoMakefile
 mdc/Makefile
@@ -232,16 +208,16 @@ ost/Makefile
 ost/autoMakefile
 portals/Kernelenv
 portals/Makefile
+portals/autoMakefile
 portals/doc/Makefile
 portals/knals/Makefile
+portals/knals/autoMakefile
 portals/knals/gmnal/Makefile
 portals/knals/gmnal/autoMakefile
 portals/knals/ibnal/Makefile
 portals/knals/ibnal/autoMakefile
 portals/knals/qswnal/Makefile
 portals/knals/qswnal/autoMakefile
-portals/knals/scimacnal/Makefile
-portals/knals/scimacnal/autoMakefile
 portals/knals/socknal/Makefile
 portals/knals/socknal/autoMakefile
 portals/libcfs/Makefile
@@ -266,8 +242,9 @@ smfs/autoMakefile
 snapfs/Makefile
 snapfs/autoMakefile
 snapfs/utils/Makefile
+cmobd/Makefile
+cmobd/autoMakefile
 tests/Makefile
 utils/Lustre/Makefile
 utils/Makefile
-utils/lconf
 ])