Whamcloud - gitweb
LU-12635 build: Support for gcc -Wimplicit-fallthrough
[fs/lustre-release.git] / lustre / conf / Makefile.am
index 7e4f3ba..a5ae94c 100644 (file)
 #
 # You should have received a copy of the GNU General Public License
 # version 2 along with this program; If not, see
-# http://www.sun.com/software/products/lustre/docs/GPLv2.pdf
-#
-# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
-# CA 95054 USA or visit www.sun.com if you need additional information or
-# have any questions.
+# http://www.gnu.org/licenses/gpl-2.0.html
 #
 # GPL HEADER END
 #
@@ -28,7 +24,7 @@
 # Copyright (c) 2003, 2010, Oracle and/or its affiliates. All rights reserved.
 # Use is subject to license terms.
 #
-# Copyright (c) 2014, Intel Corporation.
+# Copyright (c) 2014, 2015, Intel Corporation.
 #
 
 #
 # Lustre is a trademark of Sun Microsystems, Inc.
 #
 
-EXTRA_DIST = lustre.dtd slapd-lustre.conf lustre2ldif.xsl top.ldif \
-             99-lustre.rules lustre ldev.conf
-ldapconfdir = $(sysconfdir)/openldap
+SUBDIRS = resource
+DIST_SUBDIRS = resource
+
+EXTRA_DIST = lustre.dtd lustre2ldif.xsl top.ldif \
+             99-lustre.rules lustre ldev.conf ko2iblnd.conf lsvcgss \
+             lnet_routes.conf lnet.conf lgssc.conf 99-lustre-server.rules
+
+sysconf_DATA = lnet.conf
 
 if UTILS
-noinst_SCRIPTS = slapd-lustre.conf
 noinst_DATA = top.ldif lustre2ldif.xsl
+sysconf_DATA += lnet_routes.conf
 endif
 
 udevrulesdir = $(sysconfdir)/udev/rules.d
 udevrules_DATA = 99-lustre.rules
 
-if RHEL
 if SERVER
+udevrules_DATA += 99-lustre-server.rules
+if ZFS_ENABLED
+sysconf_DATA += ldev.conf
+endif
+if RHEL
 sysconfigdir = $(sysconfdir)/sysconfig
 sysconfig_DATA = lustre
+if GSS_KEYRING
+sysconfig_DATA += lsvcgss
+endif
+endif
 endif
+if GSS_KEYRING
+requestkeydir = $(sysconfdir)/request-key.d
+requestkey_DATA = lgssc.conf
 endif
 
-sysconf_DATA = ldev.conf
+modprobedir = $(sysconfdir)/modprobe.d
+modprobe_DATA = ko2iblnd.conf