Whamcloud - gitweb
LU-4788 lfsck: replace cfs_list_t with list_head
[fs/lustre-release.git] / lustre / conf / Makefile.am
index f575e97..5797eed 100644 (file)
@@ -14,8 +14,8 @@
 # in the LICENSE file that accompanied this code).
 #
 # You should have received a copy of the GNU General Public License
-# version 2 along with this program; If not, see [sun.com URL with a
-# copy of GPLv2].
+# version 2 along with this program; If not, see
+# http://www.sun.com/software/products/lustre/docs/GPLv2.pdf
 #
 # Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
 # CA 95054 USA or visit www.sun.com if you need additional information or
@@ -25,7 +25,7 @@
 #
 
 #
-# Copyright  2008 Sun Microsystems, Inc. All rights reserved
+# Copyright (c) 2003, 2010, Oracle and/or its affiliates. All rights reserved.
 # Use is subject to license terms.
 #
 
 # Lustre is a trademark of Sun Microsystems, Inc.
 #
 
-EXTRA_DIST = lustre.dtd lustre.schema slapd-lustre.conf lustre2ldif.xsl top.ldif
+EXTRA_DIST = lustre.dtd slapd-lustre.conf lustre2ldif.xsl top.ldif \
+             99-lustre.rules lustre ldev.conf
 ldapconfdir = $(sysconfdir)/openldap
-ldapschemadir = $(sysconfdir)/openldap/schema
 
 if UTILS
-ldapconf_SCRIPTS = slapd-lustre.conf
-ldapschema_SCRIPTS = lustre.schema
-pkgdata_DATA = top.ldif lustre2ldif.xsl
+noinst_SCRIPTS = slapd-lustre.conf
+noinst_DATA = top.ldif lustre2ldif.xsl
 endif
+
+udevrulesdir = $(sysconfdir)/udev/rules.d
+udevrules_DATA = 99-lustre.rules
+
+if INIT_SCRIPTS
+if SERVER
+sysconfigdir = $(sysconfdir)/sysconfig
+sysconfig_DATA = lustre
+endif
+endif
+
+sysconf_DATA = ldev.conf