Whamcloud - gitweb
LU-9439 scripts: Provide a sample lnet.conf file
[fs/lustre-release.git] / lustre / conf / Makefile.am
index 7f98129..562a352 100644 (file)
@@ -1,13 +1,63 @@
-# Copyright (C) 2001  Cluster File Systems, Inc.
 #
-# This code is issued under the GNU General Public License.
-# See the file COPYING in this distribution
+# GPL HEADER START
+#
+# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2 only,
+# as published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# General Public License version 2 for more details (a copy is included
+# in the LICENSE file that accompanied this code).
+#
+# You should have received a copy of the GNU General Public License
+# version 2 along with this program; If not, see
+# http://www.gnu.org/licenses/gpl-2.0.html
+#
+# GPL HEADER END
+#
 
-EXTRA_DIST = lustre2ldif.xsl lustre.dtd lustre.schema slapd-lustre.conf
+#
+# Copyright (c) 2003, 2010, Oracle and/or its affiliates. All rights reserved.
+# Use is subject to license terms.
+#
+# Copyright (c) 2014, 2015, Intel Corporation.
+#
+
+#
+# This file is part of Lustre, http://www.lustre.org/
+# Lustre is a trademark of Sun Microsystems, Inc.
+#
+
+EXTRA_DIST = lustre.dtd slapd-lustre.conf lustre2ldif.xsl top.ldif \
+             99-lustre.rules lustre ldev.conf ko2iblnd.conf lsvcgss \
+             lnet_routes.conf lnet.conf
 ldapconfdir = $(sysconfdir)/openldap
-ldapschemadir = $(sysconfdir)/openldap/schema
-ldapconf_SCRIPTS = slapd-lustre.conf
-ldapschema_SCRIPTS = lustre.schema
 
-include $(top_srcdir)/Rules
+sysconf_DATA = ldev.conf
+
+if UTILS
+noinst_SCRIPTS = slapd-lustre.conf
+noinst_DATA = top.ldif lustre2ldif.xsl
+sysconf_DATA += lnet_routes.conf
+endif
+
+udevrulesdir = $(sysconfdir)/udev/rules.d
+udevrules_DATA = 99-lustre.rules
+
+if RHEL
+if SERVER
+sysconfigdir = $(sysconfdir)/sysconfig
+sysconfig_DATA = lustre lsvcgss
+endif
+endif
+
+if BUILD_DLC
+sysconf_DATA += lnet.conf
+endif
 
+modprobedir = $(sysconfdir)/modprobe.d
+modprobe_DATA = ko2iblnd.conf