Whamcloud - gitweb
remove unecessary debugging
[fs/lustre-release.git] / lustre / Makefile.am
index 9f837ad..045bace 100644 (file)
@@ -8,22 +8,25 @@ AUTOMAKE_OPTIONS = foreign
 if LINUX25
 DIRS24 = 
 else
-DIRS24 = extN ptlbd
+DIRS24 = ptlbd
 endif
 
 if LIBLUSTRE
-#SUBDIRS = lov obdclass ptlrpc obdecho ldlm osc liblustre utils
-SUBDIRS = lov obdclass ptlrpc obdecho ldlm osc utils
+SUBDIRS = portals obdclass lov ptlrpc obdecho osc utils mdc lvfs liblustre
 else
-# NOTE: keep extN before obdclass, mds, and obdfilter.  Keep obdclass as early
-# as possible, to have the best chance at stopping with "wrong kernel version"
-# instead of some related build failure.
-SUBDIRS = $(DIRS24) obdclass mds utils ptlrpc ldlm lib obdfilter mdc osc ost
-SUBDIRS+= llite obdecho lov cobd tests doc scripts conf
+SUBDIRS = lvfs portals obdclass include $(DIRS24) mds utils obdfilter mdc osc ost 
+SUBDIRS+= llite obdecho lov cobd tests doc scripts conf ptlrpc
 endif
 
-DIST_SUBDIRS = $(SUBDIRS)
-EXTRA_DIST = BUGS FDL Rules include archdep.m4 kernel_patches
+if SNAPFS
+SUBDIRS+= snapfs
+endif
+
+if SMFS 
+SUBDIRS += smfs
+endif
+DIST_SUBDIRS = $(SUBDIRS) liblustre snapfs smfs
+EXTRA_DIST = BUGS FDL Rules kernel_patches
 
 # We get the version from the spec file.
 CONFIGURE_DEPENDENCIES = scripts/lustre.spec.in
@@ -36,3 +39,20 @@ include $(top_srcdir)/Rules
 
 rpms: dist Makefile
        rpmbuild -ta $(distdir).tar.gz
+
+CSTK=/tmp/checkstack
+CSTKO=/tmp/checkstack.orig
+
+checkstack:
+       [ -f ${CSTK} -a ! -s ${CSTKO} ] && mv ${CSTK} ${CSTKO} || true
+       for i in ${SUBDIRS} portals/knals/*; do                              \
+               MOD=$$i/`basename $$i`.o;                                    \
+               [ -f $$MOD ] && objdump -d $$MOD | perl tests/checkstack.pl; \
+       done | sort -nr > ${CSTK}
+       [ -f ${CSTKO} ] && ! diff -u ${CSTKO} ${CSTK} || head -30 ${CSTK}
+
+checkstack-update:
+       [ -f ${CSTK} ] && mv ${CSTK} ${CSTKO}
+
+checkstack-clean:
+       rm -f ${CSTK} ${CSTKO}