Whamcloud - gitweb
remove unecessary debugging
[fs/lustre-release.git] / lustre / Makefile.am
index 6fcadf3..045bace 100644 (file)
@@ -6,17 +6,27 @@
 AUTOMAKE_OPTIONS = foreign
 
 if LINUX25
-DIRS24 = mds
+DIRS24 = 
 else
-DIRS24 = extN mds
+DIRS24 = ptlbd
 endif
 
-# NOTE: keep extN before mds and obdfilter
-SUBDIRS = $(DIRS24) obdclass utils ptlrpc ldlm lib obdfilter mdc osc ost llite 
-SUBDIRS+= obdecho lov tests doc scripts 
+if LIBLUSTRE
+SUBDIRS = portals obdclass lov ptlrpc obdecho osc utils mdc lvfs liblustre
+else
+SUBDIRS = lvfs portals obdclass include $(DIRS24) mds utils obdfilter mdc osc ost 
+SUBDIRS+= llite obdecho lov cobd tests doc scripts conf ptlrpc
+endif
 
-DIST_SUBDIRS = $(SUBDIRS)
-EXTRA_DIST = BUGS FDL Rules include patches archdep.m4
+if SNAPFS
+SUBDIRS+= snapfs
+endif
+
+if SMFS 
+SUBDIRS += smfs
+endif
+DIST_SUBDIRS = $(SUBDIRS) liblustre snapfs smfs
+EXTRA_DIST = BUGS FDL Rules kernel_patches
 
 # We get the version from the spec file.
 CONFIGURE_DEPENDENCIES = scripts/lustre.spec.in
@@ -28,4 +38,21 @@ dist-hook:
 include $(top_srcdir)/Rules
 
 rpms: dist Makefile
-       rpm -ta $(distdir).tar.gz
+       rpmbuild -ta $(distdir).tar.gz
+
+CSTK=/tmp/checkstack
+CSTKO=/tmp/checkstack.orig
+
+checkstack:
+       [ -f ${CSTK} -a ! -s ${CSTKO} ] && mv ${CSTK} ${CSTKO} || true
+       for i in ${SUBDIRS} portals/knals/*; do                              \
+               MOD=$$i/`basename $$i`.o;                                    \
+               [ -f $$MOD ] && objdump -d $$MOD | perl tests/checkstack.pl; \
+       done | sort -nr > ${CSTK}
+       [ -f ${CSTKO} ] && ! diff -u ${CSTKO} ${CSTK} || head -30 ${CSTK}
+
+checkstack-update:
+       [ -f ${CSTK} ] && mv ${CSTK} ${CSTKO}
+
+checkstack-clean:
+       rm -f ${CSTK} ${CSTKO}