Whamcloud - gitweb
LU-12478 build: rhel8 missing module packaing tools
[fs/lustre-release.git] / lustre.spec.in
index 240bf82..db3c0d4 100644 (file)
@@ -159,6 +159,13 @@ BuildRequires: libselinux-devel
 Requires: libselinux
 %endif
 %if %{with lustre_modules}
+
+%if 0%{?rhel} >= 8
+%if %{undefined kernel_module_package_buildreqs}
+BuildRequires: redhat-rpm-config kernel-rpm-macros elfutils-libelf-devel kmod
+%endif
+%endif
+
 BuildRequires: %kernel_module_package_buildreqs
 %if %{_vendor}=="redhat"
 BuildRequires: redhat-rpm-config