Whamcloud - gitweb
LU-12269 build: fix hardened builds in rpm spec file
[fs/lustre-release.git] / lnet / utils / Makefile.am
index ab9ef92..fdd0918 100644 (file)
 #
 # You should have received a copy of the GNU General Public License
 # version 2 along with this program; If not, see
-# http://www.sun.com/software/products/lustre/docs/GPLv2.pdf
-#
-# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
-# CA 95054 USA or visit www.sun.com if you need additional information or
-# have any questions.
+# http://www.gnu.org/licenses/gpl-2.0.html
 #
 # GPL HEADER END
 #
 # Lustre is a trademark of Sun Microsystems, Inc.
 #
 
-AM_CFLAGS  := -fPIC -D_GNU_SOURCE
-AM_LDFLAGS := -L.
+AM_CFLAGS  := -fPIC -D_GNU_SOURCE $(UTILS_CFLAGS)
+AM_LDFLAGS := -L. $(UTILS_LDFLAGS)
 
-if BUILD_DLC
 SUBDIRS = lnetconfig
-endif # BUILD_DLC
-
-LIBCFS= $(top_builddir)/libcfs/libcfs/libcfs.a
-LIBCFSUTIL= $(top_builddir)/libcfs/libcfs/libcfsutil.a
 
 if UTILS
-sbin_PROGRAMS = routerstat lst
-
-if BUILD_DLC
-sbin_PROGRAMS += lnetctl
-endif # BUILD_DLC
+sbin_PROGRAMS = routerstat lst lnetctl
 
 routerstat_SOURCES = routerstat.c
-routerstat_LDADD = $(LIBCFS)
+routerstat_LDADD = $(top_builddir)/lnet/utils/lnetconfig/liblnetconfig.la
 
 lst_SOURCES = lst.c
-lst_LDADD = -lptlctl $(LIBCFSUTIL) $(LIBCFS) $(LIBREADLINE) $(LIBEFENCE)
-lst_DEPENDENCIES = libptlctl.a
+lst_LDADD = $(top_builddir)/lnet/utils/lnetconfig/liblnetconfig.la \
+           $(LIBEFENCE)
 
 if TESTS
 sbin_PROGRAMS += wirecheck
@@ -66,12 +53,7 @@ sbin_PROGRAMS += wirecheck
 wirecheck_SOURCES = wirecheck.c
 endif # TESTS
 
-lib_LIBRARIES = libptlctl.a
-libptlctl_a_SOURCES = portals.c debug.c
-
-CYAML := $(top_builddir)/lnet/utils/cyaml/cyaml.c
-lnetctl_SOURCES = lnetctl.c $(CYAML)
+lnetctl_SOURCES = lnetctl.c
 lnetctl_LDADD = $(top_builddir)/lnet/utils/lnetconfig/liblnetconfig.la \
-               $(LIBCFSUTIL) $(LIBCFS) $(LIBREADLINE) $(LIBEFENCE) -lyaml -lm
-lnetctl_DEPENDENCIES = $(top_builddir)/lnet/utils/lnetconfig/liblnetconfig.la
+               $(LIBEFENCE)
 endif # UTILS