Whamcloud - gitweb
LU-12269 build: fix hardened builds in rpm spec file
[fs/lustre-release.git] / lnet / utils / Makefile.am
index a14df1c..fdd0918 100644 (file)
@@ -1,42 +1,59 @@
-# Copyright (C) 2001  Cluster File Systems, Inc.
 #
-# This code is issued under the GNU General Public License.
-# See the file COPYING in this distribution
-
-## $(srcdir)/../ for <portals/*.h>, ../../ for generated <config.h>
-#COMPILE = $(CC) -Wall -g -I$(srcdir)/../include -I../../include
-#LINK = $(CC) -o $@
-
-if LIBLUSTRE
-noinst_LIBRARIES = libuptlctl.a
-libuptlctl_a_SOURCES = portals.c debug.c l_ioctl.c
-libuptlctl_a_CPPFLAGS = $(LLCPPFLAGS)
-libuptlctl_a_CFLAGS = $(LLCFLAGS)
-endif
-
-sbin_PROGRAMS = debugctl
+# GPL HEADER START
+#
+# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2 only,
+# as published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# General Public License version 2 for more details (a copy is included
+# in the LICENSE file that accompanied this code).
+#
+# You should have received a copy of the GNU General Public License
+# version 2 along with this program; If not, see
+# http://www.gnu.org/licenses/gpl-2.0.html
+#
+# GPL HEADER END
+#
 
-lib_LIBRARIES = libptlctl.a
+#
+# Copyright (c) 2003, 2010, Oracle and/or its affiliates. All rights reserved.
+# Use is subject to license terms.
+#
+# Copyright (c) 2013, 2015, Intel Corporation.
+#
 
-libptlctl_a_SOURCES = portals.c debug.c l_ioctl.c parser.c parser.h
+#
+# This file is part of Lustre, http://www.lustre.org/
+# Lustre is a trademark of Sun Microsystems, Inc.
+#
 
-if !CRAY_PORTALS
-sbin_PROGRAMS += acceptor ptlctl routerstat wirecheck gmnalnid
+AM_CFLAGS  := -fPIC -D_GNU_SOURCE $(UTILS_CFLAGS)
+AM_LDFLAGS := -L. $(UTILS_LDFLAGS)
 
-acceptor_SOURCES = acceptor.c
+SUBDIRS = lnetconfig
 
-wirecheck_SOURCES = wirecheck.c
+if UTILS
+sbin_PROGRAMS = routerstat lst lnetctl
 
-gmnalnid_SOURCES = gmnalnid.c
+routerstat_SOURCES = routerstat.c
+routerstat_LDADD = $(top_builddir)/lnet/utils/lnetconfig/liblnetconfig.la
 
-ptlctl_SOURCES = ptlctl.c
-ptlctl_LDADD =  -L. -lptlctl $(LIBREADLINE) $(LIBEFENCE)
-ptlctl_DEPENDENCIES = libptlctl.a
+lst_SOURCES = lst.c
+lst_LDADD = $(top_builddir)/lnet/utils/lnetconfig/liblnetconfig.la \
+           $(LIBEFENCE)
 
-routerstat_SOURCES = routerstat.c
-endif
+if TESTS
+sbin_PROGRAMS += wirecheck
 
-debugctl_SOURCES = debugctl.c
-debugctl_LDADD = -L. -lptlctl $(LIBREADLINE) $(LIBEFENCE)
-debugctl_DEPENDENCIES = libptlctl.a
+wirecheck_SOURCES = wirecheck.c
+endif # TESTS
 
+lnetctl_SOURCES = lnetctl.c
+lnetctl_LDADD = $(top_builddir)/lnet/utils/lnetconfig/liblnetconfig.la \
+               $(LIBEFENCE)
+endif # UTILS