Whamcloud - gitweb
land v0.9.1 on HEAD, in preparation for a 1.0.x branch
[fs/lustre-release.git] / lnet / utils / Makefile.am
index 05af598..f1878df 100644 (file)
@@ -4,10 +4,16 @@
 # See the file COPYING in this distribution
 
 
-COMPILE = gcc -Wall -g -I$(srcdir)/../include 
-LINK = gcc -o $@
+COMPILE = $(CC) -Wall -g -I$(srcdir)/../include
+LINK = $(CC) -o $@
 
-sbin_PROGRAMS = acceptor ptlctl debugctl routerstat wirecheck
+if LIBLUSTRE
+tmp=
+else
+tmp=gmnalnid
+endif
+
+sbin_PROGRAMS = acceptor ptlctl debugctl routerstat wirecheck $(tmp)
 lib_LIBRARIES = libptlctl.a
 
 acceptor_SOURCES = acceptor.c # -lefence
@@ -16,6 +22,8 @@ wirecheck_SOURCES = wirecheck.c
 
 libptlctl_a_SOURCES = portals.c debug.c l_ioctl.c parser.c parser.h
 
+gmnalnid_SOURCES = gmnalnid.c
+
 ptlctl_SOURCES = ptlctl.c
 ptlctl_LDADD =  -L. -lptlctl -lncurses # -lefence
 ptlctl_DEPENDENCIES = libptlctl.a