Whamcloud - gitweb
LU-2456 lnet: DLC user space Configuration utility
[fs/lustre-release.git] / lnet / utils / Makefile.am
index e871d9a..d43150d 100644 (file)
@@ -1,38 +1,83 @@
-# Copyright (C) 2001  Cluster File Systems, Inc.
 #
-# This code is issued under the GNU General Public License.
-# See the file COPYING in this distribution
+# GPL HEADER START
+#
+# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2 only,
+# as published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# General Public License version 2 for more details (a copy is included
+# in the LICENSE file that accompanied this code).
+#
+# You should have received a copy of the GNU General Public License
+# version 2 along with this program; If not, see
+# http://www.sun.com/software/products/lustre/docs/GPLv2.pdf
+#
+# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
+# CA 95054 USA or visit www.sun.com if you need additional information or
+# have any questions.
+#
+# GPL HEADER END
+#
 
-# ../ for <portals/*.h>, ../../ for <config.h>
-COMPILE = $(CC) -Wall -g -I$(srcdir)/../include -I$(srcdir)/../../include
-LINK = $(CC) -o $@
+#
+# Copyright (c) 2003, 2010, Oracle and/or its affiliates. All rights reserved.
+# Use is subject to license terms.
+#
 
-if LIBLUSTRE
+#
+# This file is part of Lustre, http://www.lustre.org/
+# Lustre is a trademark of Sun Microsystems, Inc.
+#
 
-noinst_LIBRARIES = libuptlctl.a
-libuptlctl_a_SOURCES = portals.c debug.c l_ioctl.c parser.c parser.h
-libuptlctl_a_CFLAGS = -fPIC
+AM_CFLAGS = $(LLCFLAGS)
 
-else
+if BUILD_DLC
+SUBDIRS = lnetconfig
+endif
 
-sbin_PROGRAMS = acceptor ptlctl debugctl routerstat wirecheck gmnalnid
-lib_LIBRARIES = libptlctl.a
+AM_LDFLAGS := -L$(top_builddir)/lnet/utils/lnetconfig
 
-acceptor_SOURCES = acceptor.c # -lefence
+LIBCFS= $(top_builddir)/libcfs/libcfs/libcfs.a
+LIBCFSUTIL= $(top_builddir)/libcfs/libcfs/libcfsutil.a
 
-wirecheck_SOURCES = wirecheck.c
+if UTILS
+sbin_PROGRAMS = routerstat lst
 
-libptlctl_a_SOURCES = portals.c debug.c l_ioctl.c parser.c parser.h
+if BUILD_DLC
+sbin_PROGRAMS += lnetctl
+endif
 
-gmnalnid_SOURCES = gmnalnid.c
+routerstat_SOURCES = routerstat.c
 
-ptlctl_SOURCES = ptlctl.c
-ptlctl_LDADD =  -L. -lptlctl $(LIBREADLINE) $(LIBEFENCE)
-ptlctl_DEPENDENCIES = libptlctl.a
+lst_SOURCES = lst.c
+lst_LDADD = -L. -lptlctl $(LIBCFSUTIL) $(LIBCFS) $(LIBREADLINE) $(LIBEFENCE)
+lst_DEPENDENCIES = libptlctl.a
 
-debugctl_SOURCES = debugctl.c
-debugctl_LDADD = -L. -lptlctl $(LIBREADLINE) $(LIBEFENCE)
-debugctl_DEPENDENCIES = libptlctl.a
+if TESTS
+sbin_PROGRAMS += wirecheck
 
-routerstat_SOURCES = routerstat.c
+wirecheck_SOURCES = wirecheck.c
+endif
+
+lib_LIBRARIES = libptlctl.a
+
+libptlctl_a_SOURCES = portals.c debug.c
+
+CYAML := $(top_builddir)/lnet/utils/cyaml/cyaml.c
+lnetctl_SOURCES = lnetctl.c $(CYAML)
+lnetctl_LDADD = -L. -lm -lyaml -llnetconfig \
+               $(LIBCFSUTIL) $(LIBCFS) $(LIBREADLINE) $(LIBEFENCE)
+lnetctl_DEPENDENCIES = $(top_builddir)/lnet/utils/lnetconfig/liblnetconfig.so
+endif # UTILS
+
+LND_LIBS =
+if BUILD_USOCKLND
+LND_LIBS += $(top_builddir)/lnet/ulnds/socklnd/libsocklnd.a
 endif
+
+EXTRA_DIST = genlib.sh