Whamcloud - gitweb
LU-2456 lnet: DLC user space Configuration utility
[fs/lustre-release.git] / lnet / utils / Makefile.am
index 523d1d7..d43150d 100644 (file)
@@ -1,82 +1,83 @@
-# Copyright (C) 2001  Cluster File Systems, Inc.
 #
-# This code is issued under the GNU General Public License.
-# See the file COPYING in this distribution
-
-## $(srcdir)/../ for <portals/*.h>, ../../ for generated <config.h>
-#COMPILE = $(CC) -Wall -g -I$(srcdir)/../include -I../../include
-#LINK = $(CC) -o $@
-
-if LIBLUSTRE
-noinst_LIBRARIES = libuptlctl.a
-endif
+# GPL HEADER START
+#
+# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2 only,
+# as published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# General Public License version 2 for more details (a copy is included
+# in the LICENSE file that accompanied this code).
+#
+# You should have received a copy of the GNU General Public License
+# version 2 along with this program; If not, see
+# http://www.sun.com/software/products/lustre/docs/GPLv2.pdf
+#
+# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
+# CA 95054 USA or visit www.sun.com if you need additional information or
+# have any questions.
+#
+# GPL HEADER END
+#
 
-libuptlctl_a_SOURCES = portals.c nidstrings.c debug.c l_ioctl.c
-libuptlctl_a_CPPFLAGS = $(LLCPPFLAGS)
-libuptlctl_a_CFLAGS = $(LLCFLAGS) -DLUSTRE_UTILS=1
+#
+# Copyright (c) 2003, 2010, Oracle and/or its affiliates. All rights reserved.
+# Use is subject to license terms.
+#
 
-sbin_PROGRAMS = debugctl
+#
+# This file is part of Lustre, http://www.lustre.org/
+# Lustre is a trademark of Sun Microsystems, Inc.
+#
 
-lib_LIBRARIES = libptlctl.a
+AM_CFLAGS = $(LLCFLAGS)
 
-if LIBLUSTRE
-noinst_LIBRARIES += liblst.a
-liblst_a_SOURCES =
+if BUILD_DLC
+SUBDIRS = lnetconfig
 endif
 
-libptlctl_a_SOURCES = portals.c nidstrings.c debug.c l_ioctl.c parser.c parser.h
+AM_LDFLAGS := -L$(top_builddir)/lnet/utils/lnetconfig
+
+LIBCFS= $(top_builddir)/libcfs/libcfs/libcfs.a
+LIBCFSUTIL= $(top_builddir)/libcfs/libcfs/libcfsutil.a
 
 if UTILS
-sbin_PROGRAMS += ptlctl routerstat wirecheck lst
-if LIBLUSTRE
-sbin_PROGRAMS += lstclient
-endif
+sbin_PROGRAMS = routerstat lst
 
-if BUILD_GMLND
-sbin_PROGRAMS += gmlndnid
+if BUILD_DLC
+sbin_PROGRAMS += lnetctl
 endif
-endif
-
-wirecheck_SOURCES = wirecheck.c
-
-gmlndnid_SOURCES = gmlndnid.c
-gmlndnid_CFLAGS = $(GMCPPFLAGS)
-gmlndnid_LDFLAGS = -static
-gmlndnid_LDADD = $(GMLIBS) -lgm
-
-ptlctl_SOURCES = ptlctl.c
-ptlctl_LDADD =  -L. -lptlctl $(LIBREADLINE) $(LIBEFENCE)
-ptlctl_DEPENDENCIES = libptlctl.a
 
 routerstat_SOURCES = routerstat.c
 
-debugctl_SOURCES = debugctl.c
-debugctl_LDADD = -L. -lptlctl $(LIBREADLINE) $(LIBEFENCE)
-debugctl_DEPENDENCIES = libptlctl.a
-
 lst_SOURCES = lst.c
-lst_LDADD = -L. -lptlctl $(LIBREADLINE) $(LIBEFENCE)
+lst_LDADD = -L. -lptlctl $(LIBCFSUTIL) $(LIBCFS) $(LIBREADLINE) $(LIBEFENCE)
 lst_DEPENDENCIES = libptlctl.a
 
-LND_LIBS =
-if BUILD_USOCKLND
-LND_LIBS +=    $(top_builddir)/lnet/ulnds/socklnd/libsocklnd.a
-endif
-if BUILD_UPTLLND
-LND_LIBS +=   $(top_builddir)/lnet/ulnds/ptllnd/libptllnd.a
+if TESTS
+sbin_PROGRAMS += wirecheck
+
+wirecheck_SOURCES = wirecheck.c
 endif
 
-if LIBLUSTRE
-LIB_SELFTEST = $(top_builddir)/libcfs/libcfs/libcfs.a $(top_builddir)/lnet/lnet/liblnet.a $(top_builddir)/lnet/selftest/libselftest.a
-liblst.a : $(LIB_SELFTEST) $(LND_LIBS)
-       sh $(srcdir)/genlib.sh "$(LIBS)" "$(LND_LIBS)" "$(PTHREAD_LIBS)"
+lib_LIBRARIES = libptlctl.a
 
-lstclient_SOURCES = lstclient.c
-lstclient_LDADD = -L. -lptlctl -llst $(LIBREADLINE) $(LIBEFENCE) $(PTHREAD_LIBS)
-lstclient_DEPENDENCIES = libptlctl.a liblst.a
-endif
+libptlctl_a_SOURCES = portals.c debug.c
 
-nidstrings.c: @top_srcdir@/libcfs/libcfs/nidstrings.c
-       ln -sf $< $@
+CYAML := $(top_builddir)/lnet/utils/cyaml/cyaml.c
+lnetctl_SOURCES = lnetctl.c $(CYAML)
+lnetctl_LDADD = -L. -lm -lyaml -llnetconfig \
+               $(LIBCFSUTIL) $(LIBCFS) $(LIBREADLINE) $(LIBEFENCE)
+lnetctl_DEPENDENCIES = $(top_builddir)/lnet/utils/lnetconfig/liblnetconfig.so
+endif # UTILS
+
+LND_LIBS =
+if BUILD_USOCKLND
+LND_LIBS += $(top_builddir)/lnet/ulnds/socklnd/libsocklnd.a
+endif
 
 EXTRA_DIST = genlib.sh