Whamcloud - gitweb
LU-2456 lnet: DLC user space Configuration utility
[fs/lustre-release.git] / lnet / utils / Makefile.am
index 51de201..d43150d 100644 (file)
@@ -14,8 +14,8 @@
 # in the LICENSE file that accompanied this code).
 #
 # You should have received a copy of the GNU General Public License
-# version 2 along with this program; If not, see [sun.com URL with a
-# copy of GPLv2].
+# version 2 along with this program; If not, see
+# http://www.sun.com/software/products/lustre/docs/GPLv2.pdf
 #
 # Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
 # CA 95054 USA or visit www.sun.com if you need additional information or
@@ -25,7 +25,7 @@
 #
 
 #
-# Copyright  2008 Sun Microsystems, Inc. All rights reserved
+# Copyright (c) 2003, 2010, Oracle and/or its affiliates. All rights reserved.
 # Use is subject to license terms.
 #
 
 # Lustre is a trademark of Sun Microsystems, Inc.
 #
 
-## $(srcdir)/../ for <portals/*.h>, ../../ for generated <config.h>
-#COMPILE = $(CC) -Wall -g -I$(srcdir)/../include -I../../include
-#LINK = $(CC) -o $@
+AM_CFLAGS = $(LLCFLAGS)
 
-LIBCFSUTIL= $(top_builddir)/libcfs/libcfs/libcfsutil.a
-
-if LIBLUSTRE
-noinst_LIBRARIES = libuptlctl.a
+if BUILD_DLC
+SUBDIRS = lnetconfig
 endif
 
-libuptlctl_a_SOURCES = portals.c debug.c
-libuptlctl_a_CPPFLAGS = $(LLCPPFLAGS)
-libuptlctl_a_CFLAGS = $(LLCFLAGS) -DLUSTRE_UTILS=1
+AM_LDFLAGS := -L$(top_builddir)/lnet/utils/lnetconfig
 
-sbin_PROGRAMS = debugctl
+LIBCFS= $(top_builddir)/libcfs/libcfs/libcfs.a
+LIBCFSUTIL= $(top_builddir)/libcfs/libcfs/libcfsutil.a
 
-lib_LIBRARIES = libptlctl.a
+if UTILS
+sbin_PROGRAMS = routerstat lst
 
-if LIBLUSTRE
-noinst_LIBRARIES += liblst.a
-liblst_a_SOURCES =
+if BUILD_DLC
+sbin_PROGRAMS += lnetctl
 endif
 
-libptlctl_a_SOURCES = portals.c debug.c
+routerstat_SOURCES = routerstat.c
 
-if UTILS
-sbin_PROGRAMS += ptlctl routerstat wirecheck lst
-if LIBLUSTRE
-sbin_PROGRAMS += lstclient
-endif
+lst_SOURCES = lst.c
+lst_LDADD = -L. -lptlctl $(LIBCFSUTIL) $(LIBCFS) $(LIBREADLINE) $(LIBEFENCE)
+lst_DEPENDENCIES = libptlctl.a
 
-if BUILD_GMLND
-sbin_PROGRAMS += gmlndnid
-endif
-endif
+if TESTS
+sbin_PROGRAMS += wirecheck
 
 wirecheck_SOURCES = wirecheck.c
+endif
 
-gmlndnid_SOURCES = gmlndnid.c
-gmlndnid_CFLAGS = $(GMCPPFLAGS)
-gmlndnid_LDFLAGS = -static
-gmlndnid_LDADD = $(GMLIBS) -lgm
-
-ptlctl_SOURCES = ptlctl.c
-ptlctl_LDADD =  -L. -lptlctl $(LIBCFSUTIL) $(LIBREADLINE) $(LIBEFENCE)
-ptlctl_DEPENDENCIES = libptlctl.a
-
-routerstat_SOURCES = routerstat.c
+lib_LIBRARIES = libptlctl.a
 
-debugctl_SOURCES = debugctl.c
-debugctl_LDADD = -L. -lptlctl $(LIBCFSUTIL) $(LIBREADLINE) $(LIBEFENCE)
-debugctl_DEPENDENCIES = libptlctl.a
+libptlctl_a_SOURCES = portals.c debug.c
 
-lst_SOURCES = lst.c
-lst_LDADD = -L. -lptlctl $(LIBCFSUTIL) $(LIBREADLINE) $(LIBEFENCE)
-lst_DEPENDENCIES = libptlctl.a
+CYAML := $(top_builddir)/lnet/utils/cyaml/cyaml.c
+lnetctl_SOURCES = lnetctl.c $(CYAML)
+lnetctl_LDADD = -L. -lm -lyaml -llnetconfig \
+               $(LIBCFSUTIL) $(LIBCFS) $(LIBREADLINE) $(LIBEFENCE)
+lnetctl_DEPENDENCIES = $(top_builddir)/lnet/utils/lnetconfig/liblnetconfig.so
+endif # UTILS
 
 LND_LIBS =
 if BUILD_USOCKLND
-LND_LIBS +=    $(top_builddir)/lnet/ulnds/socklnd/libsocklnd.a
-endif
-if BUILD_UPTLLND
-LND_LIBS +=   $(top_builddir)/lnet/ulnds/ptllnd/libptllnd.a
-endif
-
-if LIBLUSTRE
-LIB_SELFTEST = $(top_builddir)/libcfs/libcfs/libcfs.a $(top_builddir)/lnet/lnet/liblnet.a $(top_builddir)/lnet/selftest/libselftest.a
-liblst.a : $(LIB_SELFTEST) $(LND_LIBS)
-       sh $(srcdir)/genlib.sh "$(LIBS)" "$(LND_LIBS)" "$(PTHREAD_LIBS)"
-
-lstclient_SOURCES = lstclient.c
-lstclient_LDADD = -L. -lptlctl -llst $(LIBREADLINE) $(LIBEFENCE) $(PTHREAD_LIBS)
-lstclient_DEPENDENCIES = libptlctl.a liblst.a
+LND_LIBS += $(top_builddir)/lnet/ulnds/socklnd/libsocklnd.a
 endif
 
 EXTRA_DIST = genlib.sh