Whamcloud - gitweb
land b_eq on HEAD
[fs/lustre-release.git] / lnet / utils / Makefile.am
index f1878df..6c31b3d 100644 (file)
@@ -3,17 +3,18 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-
 COMPILE = $(CC) -Wall -g -I$(srcdir)/../include
 LINK = $(CC) -o $@
 
 if LIBLUSTRE
-tmp=
+
+noinst_LIBRARIES = libuptlctl.a
+libuptlctl_a_SOURCES = portals.c debug.c l_ioctl.c parser.c parser.h
+libuptlctl_a_CFLAGS = -fPIC
+
 else
-tmp=gmnalnid
-endif
 
-sbin_PROGRAMS = acceptor ptlctl debugctl routerstat wirecheck $(tmp)
+sbin_PROGRAMS = acceptor ptlctl debugctl routerstat wirecheck gmnalnid
 lib_LIBRARIES = libptlctl.a
 
 acceptor_SOURCES = acceptor.c # -lefence
@@ -33,3 +34,4 @@ debugctl_LDADD = -L. -lptlctl -lncurses # -lefence
 debugctl_DEPENDENCIES = libptlctl.a
 
 routerstat_SOURCES = routerstat.c
+endif