Whamcloud - gitweb
b=3031
[fs/lustre-release.git] / lnet / utils / Makefile.am
index a14df1c..609a430 100644 (file)
@@ -9,10 +9,11 @@
 
 if LIBLUSTRE
 noinst_LIBRARIES = libuptlctl.a
+endif
+
 libuptlctl_a_SOURCES = portals.c debug.c l_ioctl.c
 libuptlctl_a_CPPFLAGS = $(LLCPPFLAGS)
 libuptlctl_a_CFLAGS = $(LLCFLAGS)
-endif
 
 sbin_PROGRAMS = debugctl
 
@@ -20,23 +21,31 @@ lib_LIBRARIES = libptlctl.a
 
 libptlctl_a_SOURCES = portals.c debug.c l_ioctl.c parser.c parser.h
 
+if UTILS
 if !CRAY_PORTALS
-sbin_PROGRAMS += acceptor ptlctl routerstat wirecheck gmnalnid
+sbin_PROGRAMS += acceptor ptlctl routerstat wirecheck 
+endif
+if BUILD_GMNAL
+sbin_PROGRAMS += gmnalnid
+endif
+endif
 
 acceptor_SOURCES = acceptor.c
+acceptor_LDADD = $(LIBWRAP)
 
 wirecheck_SOURCES = wirecheck.c
 
 gmnalnid_SOURCES = gmnalnid.c
+gmnalnid_CFLAGS = $(GMCPPFLAGS)
+gmnalnid_LDFLAGS = -static
+gmnalnid_LDADD = $(GMLIBS) -lgm
 
 ptlctl_SOURCES = ptlctl.c
 ptlctl_LDADD =  -L. -lptlctl $(LIBREADLINE) $(LIBEFENCE)
 ptlctl_DEPENDENCIES = libptlctl.a
 
 routerstat_SOURCES = routerstat.c
-endif
 
 debugctl_SOURCES = debugctl.c
 debugctl_LDADD = -L. -lptlctl $(LIBREADLINE) $(LIBEFENCE)
 debugctl_DEPENDENCIES = libptlctl.a
-