Whamcloud - gitweb
LU-1406 ofd: init lu_target in OFD
[fs/lustre-release.git] / lnet / utils / Makefile.am
index 4dd8eac..5bccdf8 100644 (file)
@@ -14,8 +14,8 @@
 # in the LICENSE file that accompanied this code).
 #
 # You should have received a copy of the GNU General Public License
-# version 2 along with this program; If not, see [sun.com URL with a
-# copy of GPLv2].
+# version 2 along with this program; If not, see
+# http://www.sun.com/software/products/lustre/docs/GPLv2.pdf
 #
 # Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
 # CA 95054 USA or visit www.sun.com if you need additional information or
@@ -25,7 +25,7 @@
 #
 
 #
-# Copyright  2008 Sun Microsystems, Inc. All rights reserved
+# Copyright (c) 2003, 2010, Oracle and/or its affiliates. All rights reserved.
 # Use is subject to license terms.
 #
 
 #COMPILE = $(CC) -Wall -g -I$(srcdir)/../include -I../../include
 #LINK = $(CC) -o $@
 
+LIBCFSUTIL= $(top_builddir)/libcfs/libcfs/libcfsutil.a
+
 if LIBLUSTRE
 noinst_LIBRARIES = libuptlctl.a
 endif
 
-libuptlctl_a_SOURCES = portals.c nidstrings.c debug.c l_ioctl.c
+libuptlctl_a_SOURCES = portals.c debug.c
 libuptlctl_a_CPPFLAGS = $(LLCPPFLAGS)
 libuptlctl_a_CFLAGS = $(LLCFLAGS) -DLUSTRE_UTILS=1
 
@@ -55,38 +57,29 @@ noinst_LIBRARIES += liblst.a
 liblst_a_SOURCES =
 endif
 
-libptlctl_a_SOURCES = portals.c nidstrings.c debug.c l_ioctl.c parser.c parser.h
+libptlctl_a_SOURCES = portals.c debug.c
 
 if UTILS
 sbin_PROGRAMS += ptlctl routerstat wirecheck lst
 if LIBLUSTRE
 sbin_PROGRAMS += lstclient
 endif
-
-if BUILD_GMLND
-sbin_PROGRAMS += gmlndnid
-endif
 endif
 
 wirecheck_SOURCES = wirecheck.c
 
-gmlndnid_SOURCES = gmlndnid.c
-gmlndnid_CFLAGS = $(GMCPPFLAGS)
-gmlndnid_LDFLAGS = -static
-gmlndnid_LDADD = $(GMLIBS) -lgm
-
 ptlctl_SOURCES = ptlctl.c
-ptlctl_LDADD =  -L. -lptlctl $(LIBREADLINE) $(LIBEFENCE)
+ptlctl_LDADD =  -L. -lptlctl $(LIBCFSUTIL) $(LIBREADLINE) $(LIBEFENCE)
 ptlctl_DEPENDENCIES = libptlctl.a
 
 routerstat_SOURCES = routerstat.c
 
 debugctl_SOURCES = debugctl.c
-debugctl_LDADD = -L. -lptlctl $(LIBREADLINE) $(LIBEFENCE)
+debugctl_LDADD = -L. -lptlctl $(LIBCFSUTIL) $(LIBREADLINE) $(LIBEFENCE)
 debugctl_DEPENDENCIES = libptlctl.a
 
 lst_SOURCES = lst.c
-lst_LDADD = -L. -lptlctl $(LIBREADLINE) $(LIBEFENCE)
+lst_LDADD = -L. -lptlctl $(LIBCFSUTIL) $(LIBREADLINE) $(LIBEFENCE)
 lst_DEPENDENCIES = libptlctl.a
 
 LND_LIBS =
@@ -107,7 +100,4 @@ lstclient_LDADD = -L. -lptlctl -llst $(LIBREADLINE) $(LIBEFENCE) $(PTHREAD_LIBS)
 lstclient_DEPENDENCIES = libptlctl.a liblst.a
 endif
 
-nidstrings.c: @top_srcdir@/libcfs/libcfs/nidstrings.c
-       ln -sf $< $@
-
 EXTRA_DIST = genlib.sh