Whamcloud - gitweb
- landing of b_hd_cleanup_merge to HEAD.
[fs/lustre-release.git] / lnet / utils / Makefile.am
index a14df1c..1d9f905 100644 (file)
@@ -9,10 +9,11 @@
 
 if LIBLUSTRE
 noinst_LIBRARIES = libuptlctl.a
+endif
+
 libuptlctl_a_SOURCES = portals.c debug.c l_ioctl.c
 libuptlctl_a_CPPFLAGS = $(LLCPPFLAGS)
 libuptlctl_a_CFLAGS = $(LLCFLAGS)
-endif
 
 sbin_PROGRAMS = debugctl
 
@@ -20,10 +21,14 @@ lib_LIBRARIES = libptlctl.a
 
 libptlctl_a_SOURCES = portals.c debug.c l_ioctl.c parser.c parser.h
 
+if UTILS
 if !CRAY_PORTALS
 sbin_PROGRAMS += acceptor ptlctl routerstat wirecheck gmnalnid
+endif
+endif
 
 acceptor_SOURCES = acceptor.c
+acceptor_LDADD = $(LIBWRAP)
 
 wirecheck_SOURCES = wirecheck.c
 
@@ -34,7 +39,6 @@ ptlctl_LDADD =  -L. -lptlctl $(LIBREADLINE) $(LIBEFENCE)
 ptlctl_DEPENDENCIES = libptlctl.a
 
 routerstat_SOURCES = routerstat.c
-endif
 
 debugctl_SOURCES = debugctl.c
 debugctl_LDADD = -L. -lptlctl $(LIBREADLINE) $(LIBEFENCE)