Whamcloud - gitweb
LU-7734 lnet: fix routing selection
[fs/lustre-release.git] / lnet / utils / Makefile.am
index 015970a..16047da 100644 (file)
 #
 # You should have received a copy of the GNU General Public License
 # version 2 along with this program; If not, see
-# http://www.sun.com/software/products/lustre/docs/GPLv2.pdf
-#
-# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
-# CA 95054 USA or visit www.sun.com if you need additional information or
-# have any questions.
+# http://www.gnu.org/licenses/gpl-2.0.html
 #
 # GPL HEADER END
 #
@@ -54,8 +50,10 @@ sbin_PROGRAMS += lnetctl
 endif # BUILD_DLC
 
 routerstat_SOURCES = routerstat.c
+routerstat_LDADD = $(LIBCFS)
 
 lst_SOURCES = lst.c
+lst_CPPFLAGS = -I$(top_builddir)/lustre
 lst_LDADD = -lptlctl $(LIBCFSUTIL) $(LIBCFS) $(LIBREADLINE) $(LIBEFENCE)
 lst_DEPENDENCIES = libptlctl.a
 
@@ -66,7 +64,6 @@ wirecheck_SOURCES = wirecheck.c
 endif # TESTS
 
 lib_LIBRARIES = libptlctl.a
-
 libptlctl_a_SOURCES = portals.c debug.c
 
 CYAML := $(top_builddir)/lnet/utils/cyaml/cyaml.c