Whamcloud - gitweb
land b_eq on HEAD
[fs/lustre-release.git] / lnet / ulnds / socklnd / Makefile.am
index dc427b0..6035ca1 100644 (file)
@@ -1,5 +1,9 @@
 CPPFLAGS=
 INCLUDES=-I$(top_srcdir)/portals/include -I$(top_srcdir)/include -I$(srcdir)
-lib_LIBRARIES = libtcpnal.a
+noinst_LIBRARIES = libtcpnal.a
 pkginclude_HEADERS =  pqtimer.h dispatch.h table.h timer.h connection.h ipmap.h bridge.h procbridge.h
 libtcpnal_a_SOURCES = debug.c pqtimer.c select.c table.c pqtimer.h dispatch.h table.h timer.h address.c procapi.c proclib.c connection.c tcpnal.c connection.h
+
+if LIBLUSTRE
+libtcpnal_a_CFLAGS = -fPIC
+endif