Whamcloud - gitweb
Landing b_hd_newconfig on HEAD
[fs/lustre-release.git] / lnet / ulnds / ptllnd / Makefile.am
diff --git a/lnet/ulnds/ptllnd/Makefile.am b/lnet/ulnds/ptllnd/Makefile.am
new file mode 100644 (file)
index 0000000..e48cb85
--- /dev/null
@@ -0,0 +1,12 @@
+
+if BUILD_UPTLLND
+if LIBLUSTRE 
+noinst_LIBRARIES = libptllnd.a
+noinst_HEADERS =  ptllnd.h
+libptllnd_a_SOURCES = ptllnd.h ptllnd.c ptllnd_cb.c
+libptllnd_a_CPPFLAGS= $(LLCPPFLAGS)
+# I need $(PTLNDCPPLFLAGS) to be AFTER $(CPPFLAGS)
+# Adding them into $(AM_CFLAGS) seems wrong, but lets me get on..
+libptllnd_a_CFLAGS= $(PTLLNDCPPFLAGS) $(LLCFLAGS)
+endif
+endif