Whamcloud - gitweb
LU-11946 build: no yaml check during configure --enable-dist
[fs/lustre-release.git] / lnet / autoconf / lustre-lnet.m4
index effa0e1..1e51ba0 100644 (file)
@@ -81,10 +81,12 @@ AS_IF([test "x$enable_backoff" = xyes], [
 # fail to build if libyaml is not installed
 #
 AC_DEFUN([LN_CONFIG_DLC], [
-       AC_CHECK_LIB([yaml], [yaml_parser_initialize],
-                    [LIBYAML="libyaml"],
-                    [AC_MSG_ERROR([YAML development libraries not not installed])],
-                    [-lm])
+       AS_IF([test "x$enable_dist" = xno], [
+               AC_CHECK_LIB([yaml], [yaml_parser_initialize],
+                            [LIBYAML="libyaml"],
+                            [AC_MSG_ERROR([YAML development libraries not not installed])],
+                            [-lm])
+       ])
 ])
 
 #