Whamcloud - gitweb
Branch b1_8
[fs/lustre-release.git] / libsysio / configure.in
index 2aedbf1..4fcd3c0 100644 (file)
@@ -361,49 +361,49 @@ if test x$have_st_gen = xyes; then
 fi
 
 AC_MSG_CHECKING(whether .text pseudo-op must be used)
-AC_CACHE_VAL(sysio_asm_dot_text, [dnl
+AC_CACHE_VAL(am_cv_sysio_asm_dot_text, [dnl
 cat > conftest.s <<EOF
        .text
 EOF
-       sysio_asm_dot_text=
+       am_cv_sysio_asm_dot_text=
        if ${CC-cc} $CFLAGS -c conftest.s 2>/dev/null; then
-               sysio_asm_dot_text=.text
+               am_cv_sysio_asm_dot_text=.text
        fi
        rm -f conftest*])
-if test -z "$sysio_dot_text"; then
+if test -z "$am_cv_sysio_asm_dot_text"; then
        AC_MSG_RESULT(no)
 else
        AC_MSG_RESULT(yes)
 fi
 
 AC_CACHE_CHECK(for assembler global-symbol directive,
-  sysio_asm_global_directive, [dnl
-sysio_asm_global_directive=UNKNOWN
+  am_cv_sysio_asm_global_directive, [dnl
+am_cv_sysio_asm_global_directive=UNKNOWN
 for ac_globl in .globl .global .EXPORT; do
        cat > conftest.s <<EOF
-               ${sysio_asm_dot_text}
+               ${am_cv_sysio_asm_dot_text}
                ${ac_globl} foo
 foo:
 EOF
        if ${CC-cc} $CFLAGS -c conftest.s 2>/dev/null; then
-       sysio_asm_global_directive=${ac_globl}
+       am_cv_sysio_asm_global_directive=${ac_globl}
        fi
        rm -f conftest*
-       test $sysio_asm_global_directive != UNKNOWN && break
+       test $am_cv_sysio_asm_global_directive != UNKNOWN && break
 done])
-if test $sysio_asm_global_directive = UNKNOWN; then
+if test $am_cv_sysio_asm_global_directive = UNKNOWN; then
        AC_MSG_ERROR(cannot determine asm global directive)
 #else
-#      AC_DEFINE_UNQUOTED(ASM_GLOBAL_DIRECTIVE, ${sysio_asm_global_directive})
+#      AC_DEFINE_UNQUOTED(ASM_GLOBAL_DIRECTIVE, ${am_cv_sysio_asm_global_directive})
 fi
 
 AC_CACHE_CHECK(for .set assembler directive,
-  sysio_asm_set_directive, [dnl
+  am_cv_sysio_asm_set_directive, [dnl
 cat > conftest.s<<EOF
-${sysio_asm_dot_text}
+${am_cv_sysio_asm_dot_text}
 foo:
 .set bar, foo
-${sysio_asm_global_directive} bar
+${am_cv_sysio_asm_global_directive} bar
 EOF
        # The alpha-dec-osf1 assembler gives only a warning for `.set'
        # (but it doesn't work), so we must do a linking check to be sure.
@@ -413,53 +413,53 @@ main () { printf ("%d\n", bar); }
 EOF
        if ${CC-cc} $CFLAGS $CPPFLAGS $LDFLAGS \
           -o conftest conftest.s conftest1.c 1>&AC_FD_CC 2>&AC_FD_CC; then
-               sysio_asm_set_directive=yes
+               am_cv_sysio_asm_set_directive=yes
        else
-               sysio_asm_set_directive=no
+               am_cv_sysio_asm_set_directive=no
        fi
        rm -f conftest*])
-#if test $sysio_asm_set_directive = yes; then
+#if test $am_cv_sysio_asm_set_directive = yes; then
 #      AC_DEFINE(HAVE_ASM_SET_DIRECTIVE)
 #fi
 
-AC_CACHE_CHECK(for assembler .weak directive, sysio_asm_weak_directive,
+AC_CACHE_CHECK(for assembler .weak directive, am_cv_sysio_asm_weak_directive,
               [dnl
 cat > conftest.s <<EOF
-${sysio_dot_text}
+${am_cv_sysio_asm_dot_text}
 foo:
 .weak foo
 EOF
        if ${CC-cc} $CFLAGS -c conftest.s 2>/dev/null; then
-               sysio_asm_weak_directive=yes
+               am_cv_sysio_asm_weak_directive=yes
        else
-               sysio_asm_weak_directive=no
+               am_cv_sysio_asm_weak_directive=no
        fi
        rm -f conftest*])
 
-if test $sysio_asm_weak_directive = no; then
+if test $am_cv_sysio_asm_weak_directive = no; then
        AC_CACHE_CHECK(for assembler .weakext directive,
-                      sysio_asm_weakext_directive, [dnl
+                      am_cv_sysio_asm_weakext_directive, [dnl
 cat > conftest.s <<EOF
-${sysio_dot_text}
-${sysio_asm_global_directive} foo
+${am_cv_sysio_asm_dot_text}
+${am_cv_sysio_asm_global_directive} foo
 foo:
 .weakext bar foo
 .weakext baz
-${sysio_asm_global_directive} baz
+${am_cv_sysio_asm_global_directive} baz
 baz:
 EOF
                if ${CC-cc} $CFLAGS -c conftest.s 2>/dev/null; then
-                       sysio_asm_weakext_directive=yes
+                       am_cv_sysio_asm_weakext_directive=yes
                else
-                       sysio_asm_weakext_directive=no
+                       am_cv_sysio_asm_weakext_directive=no
                fi
                rm -f conftest*])
 fi # no .weak
 
-if test x$sysio_asm_weak_directive = xyes; then
+if test x$am_cv_sysio_asm_weak_directive = xyes; then
        AC_DEFINE(HAVE_ASM_WEAK_DIRECTIVE)
 fi
-if test x$sysio_asm_weakext_directive = xyes; then
+if test x$am_cv_sysio_asm_weakext_directive = xyes; then
        AC_DEFINE(HAVE_ASM_WEAKEXT_DIRECTIVE)
 fi