Whamcloud - gitweb
LU-1934 ofd: implement precreate batching
[fs/lustre-release.git] / libsysio / Makefile.am
index 11e6e3d..dfa4f9e 100644 (file)
@@ -48,16 +48,14 @@ OPTIONAL_YOD_SRCS =
 endif
 
 if WITH_LUSTRE_HACK
-OPTIONAL_LUSTRE_SRCDIR_SRCS = $(LUSTRE_SRCDIR_SRCS)
 # it would be better that let configure script check this
-AM_CFLAGS = -fPIC
-else
-OPTIONAL_LUSTRE_SRCDIR_SRCS = 
+OPTIONAL_LUSTRE_CFLAGS = -fPIC
 endif
 
+AM_CFLAGS = $(OPTIONAL_LUSTRE_CFLAGS)
+
 __LIBBUILD_DIR__libsysio_a_SOURCES = \
        $(SRCDIR_SRCS) \
-       $(OPTIONAL_LUSTRE_SRCDIR_SRCS) \
        $(OPTIONAL_STDFD_SRCS) \
        $(OPTIONAL_INCORE_SRCS) \
        $(OPTIONAL_SOCKETS_SRCS) \